This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFA/testsuite] Cleanup pending breakpoints


On 04/25/2013 08:41 PM, Keith Seitz wrote:
> On 04/24/2013 07:35 AM, Pedro Alves wrote:
> 
>>> Comments/questions?
>>
>> I wonder whether "allow-pending" is the right option for the "pending" tests.
>> As in, "allow" != "require".  I wonder whether we're losing test
>> coverage in those cases?
> 
> Well, yes and no. From reading through all the tests, I think the "allow-pending" option is a bit underdefined/underterministic. Many of the tests that use it pretty much would fail miserably if a real breakpoint was set instead, yet "allow-pending" doesn't fail if this happens.
> 
> IMO gdb_breakpoint should set what was requested or FAIL, 

I agree, but...

e.g., if allow-pending, ONLY pending breakpoint would produce a PASS.

...right, but then "allow" would be confusing.

> Nonetheless, since we have it already, I have patches now which add a "pending" option to gdb_breakpoint, meaning that it *must* set a pending breakpoint. Anything else will FAIL.

/me likes.

> Or I can mutate allow-pending to this new pending and eliminate the ambiguity that allow-pending introduced.

Not sure I understand the difference.  You mean, retain the "allow-pending"
spelling, but make it _require_ pending?  I'd rather not, as it's
confusing naming/API.  If in the end, there's no use in the tree for
an "allow-pending" option that allows pending but doesn't fail with a
regular non-pending breakpoint, in addition to a new "pending" option that
_requires_ pending, then I'd rather eliminate "allow-pending".

> What would you prefer?

Thanks,
-- 
Pedro Alves


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]