This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[COMMIT mainline+7.6 PATCH] Rename "set debug coff_pe_read" command to "set debug coff-pe-read". (was: Re: [COMMIT PATCH] Make "set/show debug coff_pe_read" a zuinteger instead of uinteger.)


On 03/26/2013 09:58 PM, Pierre Muller wrote:
>   Sorry about this mistake, 
> (I added this set/show command when I 
> fixed some problems with the coff pe reader).

No problem.  I blame it on the non-intuitive ado_foo function
names.

> I didn't really know the difference between the two...
>   Concerning the name of the variable,
> you are right that using hyphens instead of
> underscores seems to be the "unwritten?" rule.
>   I have no objection to switching to coff-pe-read.

Done.

(I grepped the manual to check whether it'd need to be changed there too.)

------------
Subject: Rename "set debug coff_pe_read" command to "set debug coff-pe-read".

Hyphens are much more common than underscores in command names.

gdb/
2013-03-27  Pedro Alves  <palves@redhat.com>

	* coff-pe-read.c (_initialize_coff_pe_read): Rename "set debug
	coff_pe_read" command to "set debug coff-pe-read".
---

 gdb/coff-pe-read.c |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/gdb/coff-pe-read.c b/gdb/coff-pe-read.c
index 01e9b51..4be349d 100644
--- a/gdb/coff-pe-read.c
+++ b/gdb/coff-pe-read.c
@@ -707,7 +707,7 @@ void _initialize_coff_pe_read (void);
 void
 _initialize_coff_pe_read (void)
 {
-  add_setshow_zuinteger_cmd ("coff_pe_read", class_maintenance,
+  add_setshow_zuinteger_cmd ("coff-pe-read", class_maintenance,
 			     &debug_coff_pe_read,
 			     _("Set coff PE read debugging."),
 			     _("Show coff PE read debugging."),


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]