gdb-patches archive
subject index for December, 2012

This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Re: [0/10] RFC: use gnulib more heavily + more configure fixes

[0/8] minor cleanups for the CLI

[1/2] RFC: refactor BFD check into autoconf macro

Re: [1/3] ptype completer

[1/8] refactor init_cli_cmds

[2/2] RFC: build machoread.c in more cases

Re: [2/3] some parser completion renamings

[2/8] make some cli-script functions static

Re: [3/3] RFC: tag name completion

[3/8] make symfile.c commands static

[4/8] remove call-cmds.h

[5/8] make dprintf_command static

[6/8] make apropos_command static

[7/8] make commands in infcmd.c static

[8/8] make directory_command static

[commit 1/3] remove unused variable in lynx_create_inferior.

[commit 1/6] minor ravenscar-thread cleanup

[commit 2/3] Delete unused variable in lynx_attach.

[commit 2/6] gdbarch-ification of ravenscar-thread support.

[commit 3/6] Rename ravenscar-sparc-thread.[hc] into sparc-ravenscar-thread.[hc].

[commit 4/6] change ravenscar_sparc prefixes into sparc_ravenscar...

[commit 5/6] Add ravenscar-thread support for powerpc.

[commit 6/6] Add missing backslash in configure.tgt gdb_target_ops (sparc-*-*)

[commit v2] ravenscar-thread support updates

[commit/obv] Remove trailing space in gdbarch.sh.

[commit] [doc patchv2] coding style: 0 vs. NULL + [patch] Code cleanup: skip.c

[commit] [patch] Code cleanup: Do not check symtab->FILENAME for NULL

[commit] [patch] Code cleanup: Remove search_len parameter

[commit] [patch] Fix "skip" for ambiguous linespec

[commit] [patch] Limit DW_AT_comp_dir workaround only for gcc<=4.2

[commit] [rfc] Print MI fullname even for non-existing files

[commit] Add call to autoheader in update-gnulib.sh.

[commit] Add copyright header to stubs/buildvms.com.

[commit] Add PTRACE_GETTRACESIG handling in ptrace_request_to_str

[commit] aix-thread: Fix getthrds declaration and call.

[commit] dwarf2read.c (create_dwo_in_dwp): Tweak comment.

[commit] Fix copyright years in gdbarch.h and gdbarch.c.

[commit] Fix gdb.base/stale-infcall.exp's copyright line.

[commit] Fix ranges_base handling in Fission skeleton DIEs

[commit] gdb.ada/lang_switch: Allow msg parameter to be a reference.

[commit] lynx-low.c: PTRACE_GETTHREADLIST may not be defined.

[commit] lynx-low: Add debug trace when new thread is discovered.

[commit] LynxOS: Resume the same thread when receiving a thread create/exit event.

[commit] Makefile.in: Move ravenscar-thread.c from SFILES to ALLDEPFILES.

[commit] minor dwarf2read.c cleanups

[commit] ping/FYI: [patch] Require long long for GDB

[commit] symmisc.c: whitespace fixes

[commit] symtab.c (find_pc_sect_symtab): Add comment.

[commit] update copyright notices in various GDB files.

[commit] Update copyright.py:NOT_FSF_LIST

[committed] : [PATCH 2/2] Move registering maint cmd from maint.c to symmisc.c.

Re: [committed] Remove a redundant condition check in tic6x-linux-tdep.c

[doc patch] coding style: 0 vs. NULL + [patch] Code cleanup: skip.c

[doc patchv2] coding style: 0 vs. NULL + [patch] Code cleanup: skip.c

Re: [MI][patch v2] -break-list to specify "thread-group"

[obv] Make maintenance_print_statistics static.

[obv] Partial fix to PR gdb/13443

[PATCH 0/3] dprintf tweaks

[PATCH 0/3] MI notification on trace started/stopped (V2)

Re: [PATCH 0/5] AArch64 GDB and GDBSERVER Port V2

[PATCH 0/6] Add a new field 'installed' when reporting tracepoint

[PATCH 0/8, V4] A general notification in GDB RSP

[PATCH 1/2] Move registering maint commands from maint.c to psymtalb.c

[PATCH 1/2] Put a NT_PSTATUS note on solaris cores.

[PATCH 1/2] Test case: check traceframe_usage.

Re: [PATCH 1/3] Fix segfault when unwinding JIT frames using a custom reader.

[PATCH 1/3] MI notification on trace started/stopped:basic

[PATCH 1/3] Test of breakpoint output for dprintf

Re: [PATCH 1/5] AArch64 GDB and GDBSERVER Port V2

[PATCH 1/6] Add a field 'installed' for each location of tracepoint.

Re: [PATCH 1/7] new queue.h in common/.

[PATCH 1/8] new queue.h in common/.

[PATCH 2/2] Compute traceframe usuage per tracepoint on demand.

[PATCH 2/2] Move registering maint cmd from maint.c to symmisc.c.

[PATCH 2/2] Remove all traces of Unixware.

[PATCH 2/3] async remote notification 'Trace'.

[PATCH 2/3] Remove dead code for dprintf.

Re: [PATCH 2/5] AArch64 GDB and GDBSERVER Port V2

[PATCH 2/6] Iterate over ALL_TRACEPOINTS first.

Re: [PATCH 2/7] de-couple %Stop from notification: gdbserver

[PATCH 2/8] de-couple %Stop from notification: gdbserver

Re: [PATCH 3/3] Add a test case for the jit-reader interface.

[PATCH 3/3] Assert 'printf_line' is non-null.

[PATCH 3/3] MI notification on trace stop: triggered by remote

Re: [PATCH 3/5] AArch64 GDB and GDBSERVER Port V2

[PATCH 3/6] Notify breakpoint-modified when tracepoints are downloaded.

Re: [PATCH 3/7] de-couple %Stop from notification: gdb

[PATCH 3/8] de-couple %Stop from notification: gdb

Re: [PATCH 4/5] AArch64 GDB and GDBSERVER Port V2

[PATCH 4/6] Notify breakpoint-modified when uploaded tracepoints are merged.

[PATCH 4/8] command 'set debug notification'.

[PATCH 5/6] Test tracepoints are installed or not

[PATCH 5/8] Different notification from packets.

[PATCH 6/6] Update test cases for 'installed' field.

[PATCH 6/8] Handle notification for all-stop.

[PATCH 7/8] Cleanup pending queues before resume in all-stop

[PATCH 8/8] RSP notification 'Test'.

Re: [Patch Darwin] head build fixes for i686-darwin9/x86_64-darwin10.

[PATCH FYI] MAINTAINERS: add myself to the write-after-approval list

[PATCH v10 1/3] MI: add the -catch-load and -catch-unload commands

[PATCH v10 2/3] MI: document the -catch-load/-unload commands

[PATCH v10 3/3] MI: tests for -catch-load/-catch-unload

RE: [patch v4 05/13] linux, btrace: perf_event based branch tracing

RE: [patch v4 06/13] linux, i386, amd64: enable btrace for 32bit and 64bit linux native

RE: [patch v4 07/13] xml, btrace: define btrace xml document style

RE: [patch v4 08/13] remote, btrace: add branch trace remote ops

RE: [patch v4 09/13] gdbserver, btrace: add generic btrace support

RE: [patch v4 10/13] gdbserver, linux, btrace: add btrace support for linux-low

RE: [patch v4 13/13] btrace, x86: restrict to Atom

[patch v5 00/12] branch tracing support for Atom

[patch v5 01/12] thread, btrace: add generic branch trace support

[patch v5 02/12] cli, btrace: add btrace cli

[patch v5 03/12] linux, btrace: perf_event based branch tracing

[patch v5 04/12] linux, i386, amd64: enable btrace for 32bit and 64bit linux native

[patch v5 05/12] xml, btrace: define btrace xml document style

[patch v5 06/12] remote, btrace: add branch trace remote ops

[patch v5 07/12] btrace, doc: document remote serial protocol

[patch v5 08/12] gdbserver, btrace: add generic btrace support

[patch v5 09/12] gdbserver, linux, btrace: add btrace support for linux-low

[patch v5 10/12] test, btrace: add branch tracing tests

[patch v5 11/12] test, btrace: more branch tracing tests

[patch v5 12/12] btrace, x86: disable on some processors

[patch v6 00/12] branch tracing support for Atom

[patch v6 01/12] thread, btrace: add generic branch trace support

[patch v6 02/12] cli, btrace: add btrace cli

[patch v6 03/12] linux, btrace: perf_event based branch tracing

[patch v6 04/12] linux, i386, amd64: enable btrace for 32bit and 64bit linux native

[patch v6 05/12] xml, btrace: define btrace xml document style

[patch v6 06/12] remote, btrace: add branch trace remote ops

[patch v6 07/12] btrace, doc: document remote serial protocol

[patch v6 08/12] gdbserver, btrace: add generic btrace support

[patch v6 09/12] gdbserver, linux, btrace: add btrace support for linux-low

Re: [PATCH v6 1/3] MI: add the -catch-load and -catch-unload commands

[patch v6 10/12] test, btrace: add branch tracing tests

[patch v6 11/12] test, btrace: more branch tracing tests

[patch v6 12/12] btrace, x86: disable on some processors

Re: [PATCH v7 1/3] MI: add the -catch-load and -catch-unload commands

[PATCH v8 1/3] MI: add the -catch-load and -catch-unload commands

[PATCH v8 2/3] MI: document the -catch-load/-unload commands

[PATCH v8 3/3] MI: tests for -catch-load/-catch-unload

[PATCH v9 1/3] MI: add the -catch-load and -catch-unload commands

[PATCH v9 2/3] MI: document the -catch-load/-unload commands

[PATCH v9 3/3] MI: tests for -catch-load/-catch-unload

[PATCH, committed] Add myself to write-after-approval maintainers

[PATCH, gdbserver] Pass tracepoint to 'add_traceframe_block'.

Re: [PATCH, ppc] Fix hw *points for embedded ppc in a threaded environment.

[PATCH/obvious?] Fix typo in gdb/frv-linux-tdep.c

[PATCH/RFC 01/02 v2] Refactor PRPSINFO handling on Binutils

[PATCH/RFC 02/02 v2] Refactor PRPSINFO handling on GDB

[PATCH/tilegx] tilegx bug fixes & improvements

[PATCH] $a0 stored as a DSP register on mips64

Re: [PATCH] Add CTF support to GDB [1/4] Add "-ctf" to tsave command

Re: [PATCH] Add CTF support to GDB [2/4] Fix a bug of function dwarf_expr_frame_base

Re: [PATCH] Add CTF support to GDB [3/4] ctf target

[PATCH] Add extern of output_command to utils.h

[PATCH] Add fseek to ui-file

[PATCH] Attach discard_pending_stop_replies to observer inferior_exit

Re: [PATCH] bug 14741 - in -var-update, all children get the display hint and dynamic attribute value from the root variable

[patch] Code cleanup: Do not check symtab->FILENAME for NULL

[patch] Code cleanup: Remove search_len parameter

[patch] Fix "skip" for ambiguous linespec

Re: Re: [PATCH] Fix for incorect breakpoint set in case of clang compiled binary

[PATCH] Fix gdb.arch/mips-octeon-bbit.exp copyright header

[patch] Fix gdb.dwarf2/implptr-optimized-out.S

[PATCH] Fix inconsistency of code and comments in init_psymbol_list

Re: [PATCH] Fix mi "-var-create" regression

Re: [PATCH] FreeBSD powerpc support

[patch] gdb.base/maint.exp: Handle .gdb_index.

[patch] gdbarch_syscall_pc_increment

Re: [patch] Limit DW_AT_comp_dir workaround only for gcc<=4.2

[patch] make older gcc happy mips-tdep.c

[PATCH] Move 'enum exception_event_kind' from symtab.h to breakpoint.c

[PATCH] null ptr check to prevent gdbserver from crashing

[PATCH] print_frame add info

Re: [PATCH] Python 3 support, part 1 (non-testsuite part)

Re: [PATCH] Python 3 support, part 2 (testsuite part)

[PATCH] Remove return value of fixup_psymbol_section

[patch] Skip gdb.base/kill-after-signal.exp if gdb, nosignals

[patch] Skip multi-arch.exp if i*86-linux.

[PATCH] solib-svr4.c: Remove old SCO-related code.

[PATCH] Solving compile warnings with clang

[patch] sort multi-loc bpt; fixes mb-inline.exp false gdbindex FAIL

[PATCH] Test on =breakpoint-created when reconnect

[patch] use python-config if available

[patch] validate binary before use

[PATCH] x86, perf, bts: disable BTS from Nehalem to Ivy Bridge

Re: [patch][python] 0 of 5 - Frame filters and Wrappers

Re: [patch][python] 1 of 5 - Frame filter Python C code changes.

Re: [patch][python] 2 of 5 - Frame filter MI code changes.

Re: [patch][python] 3 of 5 - Frame filter CLI/misc code changes.

Re: [patch][python] 4 of 5 - Frame filter testsuite changes

Re: [patch][python] 5 of 5 - Frame filter documentation changes

Re: [patchv2] GDB 7.2: new feature for "backtrace" that cuts path to file (remain filename)

[ping]: [PATCH] Attach discard_pending_stop_replies to observer inferior_exit

[PING][RFA] New port: CR16: BFD Changes required by the gdb port

[RFA 1/2] Allow powerpc-*-lynxos* GDBserver to send register map via XML...

[RFA 2/2] Make x86-lynx GDBserver pass XML register map to GDB.

[RFA 2/3] gdbarch-ification of ravenscar-thread support.

[RFA 3/3] Add ravenscar-thread support for powerpc.

Re: [RFA 4/5] New port: CR16: gdbserver

[RFA-v2] Fix other memory leak in solib_target_current_sos

[RFA/commit 1/2] update gnulib to 2012-11-05.

[RFA/commit 1/3] minor ravenscar-thread cleanup

[RFA/commit 2/2] Import gnulib's errno module.

[RFA/commit] Delete exc_request.defs.

[RFA/commit] Delete the gdb/osf-share directory.

[RFA/commit] Port GDB to powerpc-lynx178.

[RFA/commit] solib-darwin.c: handle PIE when attaching processes.

Re: [RFA/mingw32] environment variables are case-insensitive on win32

[RFA/OBVIOUS?] ui_file_new function missing "extern" in header.

[RFA/patch] ppc-aix: .bss relocation problem when overlapping with the .data section

[RFA] (cli/cli-cmds.c) ARI fix: Avoid assignment inside if statement

[RFA] .gitignore: Ignore *.pyc files.

[RFA] A few more Python version related testsuite fixes

[RFA] Avoid calling stat with empty name in relocate_gdb_directory

[RFA] Avoid memory leak in gdb_setup_readline

[RFA] Avoid memory leaks in set_language function.

[RFA] Fix memory leak in windows_xfer_shared_libraries

[RFA] Fix other memory leak in solib_target_current_sos

[RFA] Make contrib/ari/gdb_find.sh script more configurable

Re: [RFA] New port: CR16: BFD Changes required by the gdb port

[RFA] NEWS: Announce ppc-lynx178 support.

[RFA] Remove pre_expand_symtabs_matching quick_symbol_functions API

[RFC 0/2 gdbserver] Compute 'traceframe usage' per tracepoint

[RFC-v2] Dispose properly of registered gdbarch'es at exit.

Re: [RFC-v4] Fix .text section offset for windows DLL (was Calling __stdcall functions in the inferior)

Re: [RFC-v5] Fix .text section offset for windows DLL (was Calling __stdcall functions in the inferior)

[RFC/commit 3/3] Delete unused variable in lynx_resume

[RFC] Add handling of VK_HOME, VK_END, VK_DELETE and VK_INSERT for mingw hosts

[RFC] Add system-gdbinit infrastructure

[RFC] allow ravenscar thread support on multiple architectures

Re: [RFC] Debug Operators with GDB Python

[RFC] Dispose properly of registered gdbarch'es at exit.

[RFC] patch to refactor ppc64 specific code from ppc-linux-tdep

[rfc] Print MI fullname even for non-existing files

[RFC] Refactor doc on stop notification.

[RFC] Remove GNU/Linux ARI rule

[RFC] Require extern modifier for function prototypes in headers.

[sim] Update old contact info in GPL license notices

checked in: [RFA/commit] Delete the gdb/osf-share directory.

checked in: Re: [RFA/commit] solib-darwin.c: handle PIE when attaching processes.

checked in: Re: crash/regression with ia64 targets

Re: crash/regression with ia64 targets

crash/regression with ia64 targets (was: "Re: [PATCH] use gdbarch_addr_bits_remove for entry point address")

Display breakpoint commands as a list

Re: Display breakpoint commands as a list [PR mi/9659]

Display sub-breakpoints in the correct tuple format

Fix mingw support for Home,End,Insert and Delete keys

FYI/as-is: Patch to add support for atmel probe (avr).

FYI: fix gdbserver PR 14917

FYI: remove CY_AC_C_WORKS

FYI: remove deprecated_serial_fd

FYI: remove unused global

FYI: set dwz_file in dwarf2read.c

FYI: use accessor in solib-svr4.c

New ARI warning Fri Dec 21 01:56:22 UTC 2012

New ARI warning Fri Dec 21 02:12:44 UTC 2012

RE: New ARI warning Fri Nov 16 01:56:44 UTC 2012

New ARI warning Thu Dec 20 14:51:12 UTC 2012

New ARI warning Thu Dec 20 15:21:55 UTC 2012

New ARI warning Thu Dec 20 15:25:46 UTC 2012 in -D 2012-12-20-gmt -r gdb_7_5-branch

PING Re: [PATCH] FreeBSD powerpc support

ping/FYI: [patch] Require long long for GDB

ping: [PATCH] Add fseek to ui-file

Re: proposal for branch patches after first release

Reverted: [RFA/commit 2/2] Import gnulib's errno module.

Re: RFA: handle "MiniDebuginfo" section

RFA: remove -epoch, aka PR 7719

RFA: update MI breakpoint documentation

Re: RFC: [0/4] Fix PR c++/8888

Re: RFC: add relative file name handling for linespecs

RFC: automatic dependency tracking for gdbserver

RFC: close-on-exec internal file descriptors

Re: RFC: fix bug in DW_OP_GNU_implicit_pointer

Re: RFC: fix cast to void

Re: RFC: fix PR 13987

RFC: fix PR 14442 - DW_TAG_restrict_type

RFC: fix PR symtab/14931

Re: RFC: implement "catch signal"

Re: RFC: implement 'info proc mappings' for core files

RFC: make lookup_solib_trampoline_symbol_by_pc static

RFC: minor defs.h cleanup

Re: RFC: really free pending_blocks, v2

RFC: remove deprecated report_transfer_performance

RFC: remove deprecated_sym_private

RFC: remove deprecated_sym_stab_info

RFC: remove ObjC string/char-printing functions

Re: RFC: remove partial_symtab::objfile

Re: RFC: use const struct block * in more places

Update sim's COPYING files

Update some sim copyright headers to GPLv3-or-later

Re: Updated patch for Bug 13217 - thread apply all detach throws a SEGFAULT


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc 2.6.3