This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH 4/4 v3] Documentation and testsuite changes


>>>>> "Sergio" == Sergio Durigan Junior <sergiodj@redhat.com> writes:

Sergio> +# Run the tests.  We run the tests two different ways: once with a
Sergio> +# plain probe, and once with a probe that has an associated semaphore.
Sergio> +# This returns -1 on failure to compile or start, 0 otherwise.
Sergio> +proc stap_test {{arg ""}} {
[...]
Sergio> +proc stap_test_no_debuginfo {{ arg "" }} {
Sergio> +    global testfile hex
Sergio> +
Sergio> +    if {[prepare_for_testing ${testfile}.exp ${testfile} ${testfile}.c \
[...]

I think it would be preferable if each different set of tests used a
different name for the built executable.  This sort of thing makes it
simpler to debug failing tests.  Also I think it is a newly agreed-upon
convention.

Sergio> diff --git a/gdb/testsuite/gdb.trace/stap-trace.exp b/gdb/testsuite/gdb.trace/stap-trace.exp
[...]
Sergio> +proc compile_stap_bin {{ arg "" }} {
[...]
Sergio> +    if { [gdb_compile "$srcdir/$subdir/$srcfile" $binfile \
Sergio> +	    executable [concat $arg debug nowarnings]] != "" } {

Same here.

Tom


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]