This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: cu_offset vs. sect_offset field names bikeshedding [Re: [patch 2/2] typedef-checking for CU relative vs. absolute offsets]


>>>>> "Jan" == Jan Kratochvil <jan.kratochvil@redhat.com> writes:

>> >>>>> "Jan" == Jan Kratochvil <jan.kratochvil@redhat.com> writes:
Jan> typedef struct { unsigned int co; } cu_offset;
Jan> typedef struct { unsigned int so; } sect_offset;

Jan> I find 'cu_offset' + 'sect_offset' names for the types are OK, any
Jan> objective?

I think they are ok too.  DWARF doesn't provide these terms exactly, but
pretty close, e.g.:

    For DW_OP_call2 and DW_OP_call4, the operand is the 2- or 4-byte
    unsigned offset, respectively, of a debugging information entry in the
    current compilation unit.

and

    The operand is used as the offset of a debugging information entry
    in a .debug_info or .debug_types section

Tom


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]