This is the mail archive of the mailing list for the GDB project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [rfc target-side break conditions 3/5 v2] GDB-side changes

>>>>> "Luis" == Luis Gustavo <> writes:

Luis> A few more changes on this patch. It addresses all the previous
Luis> comments and suggestions.

I have a few minor notes, nothing serious.
I think someone other than me should do the final review of this patch.

A couple other things I wanted to mention --

First, I think this is a great patch series and I like it quite a bit.
I want to see it go in.

Second, I was wondering if you have any plans to extend agent
expressions to provide more coverage for DWARF expressions.  It would be
somewhat interesting, I think, to get some idea of how often GCC
generates untranslatable expressions for real code.  (Like, looking at
all the DWARF expressions in the distro... or at least some big

Luis> +static const char *condition_evaluation_enums[] = {

After Jan's patch I think you will need another const in there.

Luis> +/* Translate a condition evaluation mode MODE into either "gdb"
Luis> +   or "target.  This is used mostly to translate from "auto" to the

Missing quote after "target".

Luis> +  /* Signals that the condition has changed since the last time
Luis> +     we updated the global location list.  This means the condition
Luis> +     needs to be sent to the target again.  This is used together
Luis> +     with target-side breakpoint conditions.
Luis> +
Luis> +     This field has 3 special values:
Luis> +
Luis> +     0: It means there has been no condition changes.
Luis> +
Luis> +     1: It means this location had its condition modified.
Luis> +
Luis> +     2: It means we already marked all the locations that are duplicates
Luis> +     of this location and thus we don't need to call
Luis> +     force_breakpoint_reinsertion (...) for this location.  */
Luis> +
Luis> +  char condition_changed;

How about an enum instead of numerical constants?


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]