This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [patch] const array types


> I have filed now http://gcc.gnu.org/bugzilla/show_bug.cgi?id=45765 as
> I believe it could be fixed more at the DWARF producer side.

For what it's worth, I tend to agree that this should be fixed
on the compiler side.

> I would find this patch OK even if it fixes only the TYPE_CODE_ARRAY.

I'm a little hesitant, still (but not objecting!). It it was a one-liner,
I'd be less reluctant, but I just want to make sure that the improvement
is worth the code we're adding. Yes, the output is more accurate, but
is it really all that bad to be missing the `const'?

> > +	make_cv_type (1, TYPE_VOLATILE (el_type), el_type, 0);
>                                                            ^ NULL?
> I would find NULL for a pointer parameter more readable.

I agree.

-- 
Joel


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]