gdb-patches archive
subject index for June, 2009

This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

[0/7] Implement per-type architecture

[00/15] Completely eliminate current_gdbarch

[00/19] Eliminate some more current_gdbarch uses

[01/15] Introduce get_current_arch () function

[01/19] handle_inferior_event and subroutines

[02/15] Python interpreter callback functions

[02/19] displaced stepping routines

[03/15] Revert find_function_in_inferior gdbarch changes

[03/19] set_longjmp_breakpoint

[04/15] Per-thread architecture support

[04/19] overlay support routines

[05/15] Per-frame architecture support

[05/19] construct_inferior_arguments

[06/15] Per-breakpoint architecture support

[06/19] TUI register access routines

[07/15] Per-value architecture support

[07/19] MI register access routines

[08/15] Small Java fix

[08/19] make_pv_area

[09/15] Revert C++ ABI gdbarch changes

[09/19] agent expression routines

[1/7] Eliminate builtin void type

[10/15] Basic value access routines

[10/19] record_line

[11/15] Pointer / reference type creation

[11/19] miscellanous trivial occurrences

[12/15] Disassembler routines

[12/19] target routines

[13/15] Address printing

[13/19] sparc native target

[14/15] Byte order routines - part 1

[14/15] Byte order routines - part 2

[14/19] lookup_typename and friends

[15/15] Remove current_gdbarch

[15/19] create_string_type and string value routines

[16/19] address class support

[17/19] core file support

[18/19] string_to_core_addr

[19/19] pointer/address conversion

[2/7] Eliminate builtin character types

[3/7] Eliminate builtin integer types

[4/7] Eliminate builtin float types

[5/7] Eliminate builtin flags types

[6/7] Introduce per-type architecture

[7/7] Use per-type architecture

Re: [commit/Ada] dynamic sized packed array in variant record

Re: [commit/cleanup] delete redundant ada-lang.c:evaluate_subexp

[commit] cleanup stale exec.{h|c} xfer_memory comments.

[commit] corelow.c

[commit] Fix broken decimal-float case of value_one

[commit] Inlined function support

[commit] One more current_gdbarch regression

[commit] Re-sync ALL_TARGET_OBS

[commit] Rename frame_unwind_id and frame_pc_unwind

[commit] Rename some test binaries

[commit] Support get_longjmp_target on SPU

[commit] Two more obvious current_gdbarch eliminations

[commit] Work around bad GCC DIE trees

[Forward] New ARI warning Sat Jun 20 01:52:57 UTC 2009

[Fwd: Re: [patch] try 2 - Do not allow unwinder to terminate inferior in an inferior function call if a C++ exception handler cannot be found.]

Re: [FYI] Inlining support, rough patch

[mi] -stack-list-arguments --simple-values

[MI][Patch] -exec-continue/interrupt --thread-group expects wrong id

[ob] rename local variable in break_command_really.

[ob] small append_expanded_sal cleanup.

[OB] Update ancient comment.

[obv] (reread_symbols): Reset psymtabs_addrmap to NULL

[obv] fix missing # comment markers in m32r sim

[OBV] Fix testsuite gdb.base/exe-lock.exp windows specific failure

[obv] testsuite: Detect GDB crash during runto

Re: [PATCH 0/3] catch syscall -- try 5 -- Introduction

Re: [patch 0/8] Types Garbage Collector (for VLA+Python)

Re: [PATCH 1/2] * cli/cli-decode.c (apropos_cmd): Fix avoidance of double printing.

[PATCH 1/2] * cli/cli-decode.c (apropos_cmd): Fix avoidance of double printing.

Re: [PATCH 1/2] Add an undwinder_name field to "struct frame_unwind" for use by "info frame".

[PATCH 1/2] Fix for PR gdb/9903 (part 1)

Re: [PATCH 1/2] namespace support

Re: [patch 1/8] Types GC [unloading observer]

[PATCH 2/2] * cli/cli-decode.c (apropos_cmd): Skip traversing abbreviations for prefix commands to avoid duplicates in the output.

Re: [PATCH 2/2] Add "set/show debug unwinder" prefix commands.

[PATCH 2/2] Fix for PR gdb/9903 (part 2)

Re: [PATCH 2/2] namespace support

Re: [patch 2/8] Types GC [preserve_values as observer]

Re: [patch 3/8] Types GC [display_uses_solib_p to exp_iterate]

Re: [patch 4/8] Types GC [varobj_list to all_root_varobjs]

Re: [patch 5/8] Types GC [type_group framework]

Re: [patch 6/8] Types GC [the GC itself]

Re: [patch 7/8] Types GC [GC markers]

[patch/doc] ptid from core section

[patch/stabs] Fix for warning: (Internal error: pc 0x4000000 in read in psymtab, but not in symtab.

Re: [patch] [3/5] Types reference counting [make_function_type-objfile]

Re: [patch] [3/5] Types reference counting [make_function_type-objfile]

[patch] Accelerate blocks sorting

[Patch] Add PC-relative branch support to Moxie simulator

[patch] Add self to Write After Approval list

[patch] Add support for DW_LNE_set_discriminator

[PATCH] Conditional tracepoints

Re: [PATCH] Displaced stepping (non-stop debugging) support for ARM Linux

Re: [PATCH] Displaced stepping (non-stop debugging) support for ARM Linux

Re: [patch] Eliminate quadratic slow-down on number of solibs (part 2).

Re: [patch] Eliminate quadratic slow-down on number of solibs (part 2).

Re: [patch] Eliminate quadratic slow-down on number of solibs (take 2).

Re: [patch] Eliminate quadratic slow-down on number of solibs (take 2).

[patch] Eliminate quadratic slow-down on number of solibs (take 2).

[patch] Enable parallel make check also from gdb/

[patch] Error reporting during insert_breakpoints

Re: [patch] Fix a reread_symbols regression by mmap [Re: [patch] Use mmap instead of obstack_alloc for dwarf debug sections.]

[patch] Fix a reread_symbols regression by mmap [Re: [patch] Use mmap instead of obstack_alloc for dwarf debug sections.]

Re: [patch] Fix a reread_symbols regression by mmap [Re: [patch] Use mmap instead of obstack_alloc for dwarf debug sections.]

Re: [PATCH] fix break-always test

[patch] Fix Darwin/x86 compilation

[patch] Fix for gdb.threads/staticthreads.exp failure on Linux

Re: [patch] Fix i386 memory-by-register access on amd64

Re: [patch] Fix internal-error on dead LWPs with no associated thread

[patch] Fix internal-error on dead LWPs with no associated thread

[patch] Fix parallel gdb/ make check//%

[patch] gdbserver regcache fetch all regs

[patch] gdbserver: Add qnx target

[patch] gdbserver: Add support for Z0/Z1 packets

[patch] gdbserver: qXfer multiprocess

[patch] i386-nto-tdep.c - sigcontext

Re: [patch] i386-nto-tdep.c: Add support for xmm registers.

[PATCH] New testsuite directory gdb.reverse, and tests

Re: [patch] not able to set pending breakpoint at qualified C++ function names

Re: [patch] not able to set pending breakpoint at qualified C++ function names

[patch] nto target: Code cleanup

[patch] nto target: code cleanup #2

[patch] nto-procfs.c: Add to_xfer_partial

[patch] nto-tdep cleanup

Re: [PATCH] PR backtrace/9786

Re: [patch] Remove unimplemented MI commands [Re: Learn function name by its address]

Re: [patch] Remove unimplemented MI commands [Re: Learn function name by its address]

[patch] Remove unimplemented MI commands [Re: Learn function name by its address]

[patch] Replace reread_symbols by load+free calls

Re: [patch] Set calling convention of methods

Re: [patch] solib-svr4.c - allow reading linkmap info from core without executable

Re: [patch] solib-svr4.c - allow reading linkmap info from core without executable

Re: [patch] solib-svr4.c - allow reading linkmap info from core without executable

Re: [patch] solib-svr4.c - allow reading linkmap info from core without executable

Re: [patch] solib-svr4.c - allow reading linkmap info from core without executable

[patch] Support counted strings and embedded nulls in value.string

[patch] Test result regression for gdb.base/psymtab.exp [Re: [patch] not able to set pending breakpoint at qualified C++ function names]

[patch] testsuite: Fix gdb.base/completion.exp for check// subdirectories.

[patch] testsuite: Fix racy gdb.mi/mi-nsthrexec.exp FAIL

[patch] testsuite: gdb.base/setshow.exp fix racy FAILs

Re: [patch] try 2 - Do not allow unwinder to terminate inferior in an inferior function call if a C++ exception handler cannot be found.

Re: [patch] try 2 - Do not allow unwinder to terminate inferior in an inferior function call if a C++ exception handler cannot be found.

Re: [patch] try 2 - Do not allow unwinder to terminate inferior in an inferior function call if a C++ exception handler cannot be found.

[patch] try 2 - Do not allow unwinder to terminate inferior in an inferior function call if a C++ exception handler cannot be found.

Re: [patch] Use mmap instead of obstack_alloc for dwarf debug sections.

Re: [patch] Use mmap instead of obstack_alloc for dwarf debug sections.

Re: [patch] Use mmap instead of obstack_alloc for dwarf debug sections.

Re: [patch] varobj regression by python

[PING][RFA-v2] Fix a windows bug if two watchpoints are used

[PING][RFA-v2] Fix troubles with watchpoints in DJGPP

[Precord RFA/RFC] Add process record Linux system call 64 bits support

Re: [Precord RFA/RFC] Check Linux sys_brk release memory in process record and replay.

[resolved] Re: [patch] Re: Accessing tls variables across files causes a bug

[RFA-v2] Fix a windows bug if two watchpoints are used

[RFA-v2] Fix troubles with watchpoints in DJGPP

Re: [rfa/Ada] Remove builtin types from type/value printing routines

Re: [rfa/Ada] Remove builtin types from type/value printing routines

[rfa/Ada] Remove builtin types from type/value printing routines

[rfa/Ada] Remove builtin_type_void

[rfa/Ada] Remove current_gdbarch from ensure_lval

Re: [rfa/Ada] Restructure array bounds routines to remove builtin types

Re: [rfa/Ada] Restructure array bounds routines to remove builtin types

[rfa/Ada] Restructure array bounds routines to remove builtin types

Re: [rfa/Ada] Restructure fixed array range fall-back to remove builtin types

Re: [rfa/Ada] Restructure fixed array range fall-back to remove builtin types

[rfa/Ada] Restructure fixed array range fall-back to remove builtin types

[rfa/doc] Do not use formal parameters named "current_gdbarch" in the docs

[RFA/doco] document "set/show interactive-mode"

[RFA/RFC Prec] Add Linux AMD64 process record support, (64 bits system call support) 2/3

[RFA/RFC Prec] Add Linux AMD64 process record support, (AMD64 Linux system call support) 3/3

[RFA/RFC Prec] Add Linux AMD64 process record support, (instruction set support) 1/3

[RFA/RFC Prec] Add Linux AMD64 process record support, 0/3

[RFA/RFC] Fix watchpoint troubles on windows native.

[RFA/RFC] Process record amd64 instruction set support

Re: [RFA/Windows] Remove ADD_SHARED_SYMBOL_FILES macro

Re: [RFA] AVR: link with the simulator

[RFA] breakpoint.c ARI fixes

[RFA] comdat types

[RFA] comdat types preparation

[RFA] Fix a windows bug if two watchpoints are used

Re: [RFA] Fix avr issues: handle 'next' and avr6

[RFA] Fix bug in add_alias_cmd

Re: [RFA] Fix gdbserver crash if using kill in remote connection to windows gdbserver

Re: [RFA] Fix gdbserver crash if using kill in remote connection to windows gdbserver

[RFA] Fix gdbserver crash if using kill in remote connection to windows gdbserver

[RFA] Fix problem with extended-remote if multi_process is zero

Re: [RFA] Fix too many "no debugging symbols found" warnings.

[RFA] gdb/Makefile.in

Re: [RFA] i386/amd64 h/w watchpoints in gdbserver

[RFA] NEWS entry for recent gdbserver additions

Re: [RFA] Patch to fix "reverse-next" command error

Re: [RFA] Patch to fix "reverse-step" command error

[RFA] Patch to fix reverse return from subroutine error

Re: [RFA] Patch to fix reverse-debug recursion function tail bug

Re: [RFA] Renam sutruct using_direct members

[RFA] Reverse-step/next and shared libraries (with testsuite)

[RFA] Rewrite data cache and use for stack access.

[RFA] skip_prologue_sal and sal expansion

[RFA] testsuite/gdb.base/fullname.exp fix

Re: [RFA] testsuite/lib/gdb.exp Use unbuffered stdout and stderr also for djgpp executables

[RFA] testsuite/lib/gdb.exp Use unbuffered stdout and stderr also for djgpp executables

[RFA] trailing backslash in top-level Makefile

Re: [RFA] xmm8-15 testcase

[RFA]: Update psymtab.exp for change in not found method handling

Re: [rfa][testsuite] Consolidade Python test functions in lib/gdb.exp.

Re: [RFC,v2] Yank out target_ops->to_sections

Re: [RFC,v3] Yank out target_ops->to_sections

Re: [rfc/rft] Fix incorrect static type in scm-lang.c

Re: [rfc/rft] Fix incorrect static types in mdebugread.c

[RFC] [1/2] First cut at multi-executable support.

[RFC] [2/2] First cut at multi-executable support.

[RFC] add h/w breakpoints to x86-linux gdbserver

[RFC] Add windows Thread Information Block

Re: [RFC] Allowing all threads of all|current process(es) to be resumed [new command + docs]

Re: [RFC] Allowing all threads of all|current process(es) to be resumed [new command + docs]

RE: [RFC] Allowing all threads of all|current process(es) to be resumed [new command + docs]

[rfc] Always use per-objfile types in symbol readers

Re: [rfc] Eliminate duplicated logic with decimal operations

[rfc] Eliminate some builtin_type_ instances

[rfc] Fix Java type allocation and revert make_function_type change

Re: [RFC] Fix verification of changed values for big values.

Re: [RFC] fork in multi-threaded apps, per-thread pending_fork, other follow-fork cleanups.

[rfc] Helper routines for internal array/string types

[RFC] Improve testsuite for poor expect behavior

[rfc] longjmp breakpoints (Re: [00/19] Eliminate some more current_gdbarch uses)

[rfc] Make Java types per-architecture

[rfc] More rework of the internal variable logic

[RFC] Propagate `has_section_at_zero' flag...

Re: [rfc] Remove current_gdbarch register handling from symbol readers

[rfc] Remove dead fall-back code from Pascal / Modula-2

Re: [rfc] Simplify internal variable handling

[RFC] Simplify varobj type printing

[rfc] Some changes to the examine ("x") command

Re: [RFC] Special casing dtors?

[rfc] Use LONGEST instead of value for index arithmetic

[rfc][patch] Allow GDB to display user-defined thread names

Re: [rfc][patch] Eliminate quadratic slow-down on number of solibs.

Re: [rfc][patch] Fix for gdb/10275 (mis-handling of DW_CFA_restore_state)

[rfc][patch] Fix for gdb/10275 (mis-handling of DW_CFA_restore_state)

Add define for PowerPC 405 to bfd

Add one missing _initialize_foo declaration to shut up -Wmisssing-prototypes.

Add register definitions for PowerPC 405

cleanup last traces of NATIVE_XFER_AUXV

Don't overshoot when executing cfa instructions

DWARF is_stmt flag (revisited)

Fix manythreads.exp for solaris.

Fix MI -data-read-memory regression

Fix spurious testsuite failure

Re: Fixes for a couple of infrun bugs (thread hop, revert to step thread).

Re: Fixes for a couple of infrun bugs (thread hop, revert to step thread).

further procfs.c targets allround cleanup (removes TARGET_HAS_HARDWARE_WATCHPOINTS and an nm header)

FYI: fix K&R-style definitions

FYI: fix PR 10309

FYI: remove "static" from variables in evaluator

FYI: use cleanup in zlib_decompress_section

garbage collect proc_iterate_over_mappings.

gdb.texinfo patch for -var-list-children

gdb.texinfo patch for -var-list-children (2)

Re: How to get file descriptor from abfd?

i386.record.floating.point.patch : with more testing and assurity

Make target_ops->to_has_FOO functions instead of variables.

move procfs_first_available declaration out of inferior.h

Re: Move the multi-forks support to the generic multi-inferiors support.

nto_extra_thread_info

Patch : gdbserver get_image_name on CE

Patch: add gdb.parse_and_eval

Patch: merge src and gcc copies of dwarf2.h

PATCH: PR server/10306: gdb 6.8.50.20090622-cvs failed to build on Linux/ia64

Per-type architecture (Re: [10/15] Basic value access routines)

ptid from core section

Refuse following the vfork parent if not letting the child run.

Reporting the OSABI in target descriptions.

RFA: (testsuite): make darwin as untested in bigcore.exp

RFA: build i386-darwin

Re: RFA: makes darwin-nat.c threads (and multi-processes) aware

Re: RFC: add ability to "source" Python code

RFC: fix a cleanup bug in varobj.c

RFC: implement DW_OP_call_frame_cfa

Re: RFC: next/finish/etc -vs- exceptions

RFC: parallelize "make check"

RFC: reference counting for value

Re: submition of i386.record.floating.point.patch

Submition of i386.record.floating.point.patch

Re: TR: ARI warning list change Fri May 29 01:53:26 UTC 2009

varobj bug?

varobj_get_type cleanup


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc 2.6.3