gdb-patches archive
subject index for January, 2008

This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

--pid and --core

[BUG:MI] -break-list doesn't list multiple breakpoints

[BUG?] testsuite/gdb.threads/step.exp question

Re: [BUG] BINOP_DIV and ptyp command

Re: [commit/Ada] Add handling of "ptype TYPE_NAME.FIELD0.[...].FIELDN" expressions

[commit/Ada] Add handling of "ptype TYPE_NAME.FIELD0.[...].FIELDN" expressions

[commit/ada] Add support for Ada interface types

Re: [commit/Ada] Allow "{TYPE} ADDR" expression on left hand side of assignment

[commit/Ada] Allow "{TYPE} ADDR" expression on left hand side of assignment

[commit/Ada] Always print parameters passed by reference

[commit/Ada] Better handle new array pointer encoding

[commit/Ada] Fix 'address of array subscript

[commit/Ada] Fix assert failure when doing fixed point addition/substraction

[commit/Ada] fix bug in printing packed tagged record

[commit/ada] fix crash when printing array bound

[commit/Ada] fix handling of references to packed array types

[commit/ada] Fix infinite loop when printing tagged type

[commit/Ada] fix ptype of class-wide object

[commit/Ada] fix string comparison with string slice

[commit/Ada] handle homonyms better

[commit/Ada] Improve Ada symbol name decoding routine

[commit/Ada] print $pc when language is Ada

[commit/Ada] result of function call as a parameter to another function call

[commit/obvious] Regenerate config.in

[commit/testsuite/Ada] Fix random failure in gdb.ada/print_pc.exp (hopefully?)

[commit/WWW] Fix "project ideas" link in contribute page

[commit] Add self to MAINTAINERS

[commit] Delete commented-out code in hpux-thread.c

[commit] Handle a race condition in C-c'ing a remote target

[commit] mn10300 prologue analyzer updates

[commit] Small enhancements to value_binop

[commit] Start of New Year Procedure

[commit] Switch long double default for S/390 to 128-bit

[commit] Update am33 / mn10300 signal frame support

[DOC:-file-list-exec-source-file]

Re: [gdbserver/win32] (5/11) New interrupting method : elevating the priority

[gdbserver] Make mingw32ce gdbserver build again

[libiberty] don't demangle functions named "."

[ob] Adjust float.exp for targets with optional FPU

[OB] comment fix, corelow.c

[ob] Make selftest.exp catch up with reality

[ob] Remove two obsolete macros from fork-child.c

Re: [patch 2/2] Wrap-up expression support for DFP.

Re: [patch/libiberty] IS_ABSOLUTE_PATH to handle both DOS and POSIX p ath styles

[patch/libiberty] IS_ABSOLUTE_PATH to handle both DOS and POSIX p ath styles

[PATCH: mi-cmd-file.c]

[Patch] -var-evaluate-expression NAME [FORMAT]

[PATCH] Add AT_SUN_AUXFLAGS

[PATCH] Avoid warnings from newer Cygwin DLLS

[PATCH] Disallow pseudo-registers in agent expression.

Re: [PATCH] Doc: detach-on-follow

Re: [patch] Fix disarmed hw watchpoints after inferior's fork()

[Patch] Fix for -var-update to use natural format to compare

[patch] Fix for varobj.c assertions.

[patch] Fix indentation in dbxread.c

[patch] Fix threaded inferiors in child after fork

[patch] Fix watch_thread_num testcase for ppc32

[patch] Get rid of current_gdbarch in ppc-linux-nat.c

[PATCH] Improve printf DFP support

RE: [patch] IS_ABSOLUTE_PATH to handle both DOS and POSIX path st yles

RE: [patch] IS_ABSOLUTE_PATH to handle both DOS and POSIX path st yles

Re: [patch] IS_ABSOLUTE_PATH to handle both DOS and POSIX path st yles

[patch] IS_ABSOLUTE_PATH to handle both DOS and POSIX path styles

[patch] make --disable-gdbmi work

Re: [patch] nto target update

Re: [Patch] p-exp.y: Typecast left operand of BINOP_DIV to long double

[Patch] p-exp.y: Typecast left operand of BINOP_DIV to long double

Re: [PATCH] PPC atomic single stepping testcase

[PATCH] Re: bug in mi when setting breakpoint

[patch] Remove all current_gdbarch's in mn10300

[patch] Remove BITS_BIG_ENDIAN from defs.h

[PATCH] S/390: Enable BFP ABI also for DFP

[Patch] testsuite/gdb.pascal new testcase integer.exp

[Patch] testsuite/gdb.pascal/hello.exp (binfile): Use ${EXEEXT}

[PATCH] Variable objects in multi-threaded programs

Re: [PATCH]: MI -var-set-format

[Patch]: Replace deprecated_print_address_numeric

[patch]: Replace DEPRECATED_STREQN

Re: [RFA/Ada] suppress internally-generated symbols from "info locals"

[RFA/Ada] suppress internally-generated symbols from "info locals"

[RFA/doc] Mention fork/exec catchpoints for GNU/Linux

[RFA/doco] document "set/show multiple-choice-auto-select"

[RFA/doco] Update new-year checklist (was "Re: Need to update copyright year in sources & docs")

Re: [RFA/dwarf] save nested Ada subprograms as global symbol

Re: [RFA/DWARF] Set TYPE_FLAG_STUB for enum DIEs that are declarations only

[RFA/DWARF] Set TYPE_FLAG_STUB for enum DIEs that are declarations only

Re: [RFA/x86_64] Add handling for TYPE_CODE_CHAR in inferior fun calls

Re: [RFA/x86_64] Add handling for TYPE_CODE_CHAR in inferior fun calls

[RFA] Add handling of null Ada arrays

Re: [RFA] Add option to skip prologue in "break FILE:LINENO" (take 2)

[RFA] Add option to skip prologue in "break FILE:LINENO" (take 2)

[RFA] Add target and host for NetBSD/hppa

[RFA] backtrace in mixed language applications (take 2)

[RFA] BINOP_DIV and ptyp command

[rfa] Check for void * as 3rd arg of ptrace

Re: [RFA] Don't reset watchpoint block on solib load.

[RFA] fix "ptype $pc" internal-error

[RFA] Fix "set lang auto" oddity when inferior not started yet

[RFA] Fix -break-insert -i.

[RFA] fix Ada SYMBOL_PRINT_NAME problem

Re: [RFA] Fix float argument passing in inferior function calls for ppc64

[RFA] Fix float argument passing in inferior function calls for ppc64

[RFA] fix indentation in dbxread.c

[RFA] Fix parameter coercing for Ada function calls (take 2)

[RFA] Fix print/x on references

[RFA] Handle BINOP_INTDIV in eval.c

[RFA] Handle BINOP_INTDIV in valarith.c

Re: [RFA] Handle solaris dynamic linker name change.

[RFA] handle value_binop BINOP_REM division by zero

[RFA] i386-tdep.c: Add i386_skip_noop function

[RFA] i386-tdep.c: Add i386_skip_noop function; updated

Re: [RFA] Ignore breakpoints when reading memory.

[RFA] major whitespace fix to dbxread.c, plus teensy code reorg

[RFA] make gdb.base/sigall.c more robust

[RFA] Make mi_cmd_break_insert exception-safe.

Re: [RFA] Make symbol completion language-specific

[RFA] Make type of $pc a pointer to function

Re: [RFA] Need post-processing of parameters for function calls in Ada

[RFA] Need post-processing of parameters for function calls in Ada

[RFA] New gdb.pascal testcase for integer expressions

[RFA] new set/show multiple-choice-auto-select commands

Re: [RFA] new set/show multiple-choice-auto-select commands (take 2)

Re: [RFA] new set/show multiple-choice-auto-select commands (take 2)

[RFA] new set/show multiple-choice-auto-select commands (take 2)

[RFA] NEWS entry for DFP support

[RFA] no frame needed when computing address of subprogram

Re: [RFA] patch for 2384, dangling TYPE_VPTR_BASETYPE

RE: [RFA] patch for DW_AT_comp_dir/DW_AT_name vs .debug_line inco nsistencies

RE: [RFA] patch for DW_AT_comp_dir/DW_AT_name vs .debug_line inco nsistencies

Re: [RFA] patch for DW_AT_comp_dir/DW_AT_name vs .debug_line inco nsistencies

[RFA] patch for DW_AT_comp_dir/DW_AT_name vs .debug_line inconsistencies

[RFA] Put SPE verification in macro.

Re: [RFA] Remove #include defs.h in nto-tdep.h

[RFA] Rename decimal_to_double

[RFA] Rethrow exception properly.

[RFA] Small enhancements to value_binop

Re: [RFA] Support for calling functions with decimal float arguments in PowerPC

[RFA] Support for calling functions with decimal float arguments in PowerPC

[RFA] tighten constraints in patterns in maint.exp testcase

Re: [RFA] Try 3: Use multiple locations for hardware watchpoints.

Re: [RFA] Try2: Inform about new thread in a single place.

[RFA] Use vector for varobj_list_children interface.

Re: [RFA] win32-nat.c: Restore wrongly removed code that closes two handles returned by CreateProcess

[RFA] win32-nat.c: Restore wrongly removed code that closes two handles returned by CreateProcess

[RFC-v2] Enhance backtrace for microsoft system DLL calls

[RFC/RFA?] Should break FILE:LINENO skip prologue?

[RFC/RFA] handle function homonyms in breakpoint expressions

[RFC/RFA] Wrong documentation for "&&var"?

[RFC/rs6000] suggest to get rid of rs6000_framedata...

[rfc] Get rid of current_gdbarch in amd64

[rfc] : current_gdbarch replacement in breakpoint.c

[RFC] [0/2] Get rid of current_gdbarch in tdeps

[RFC] [1/2] Get rid of current_gdbarch in tdeps (skip_prologue)

[RFC] [2/2] Get rid of current_gdbarch in tdeps

[RFC] Fix wrong use of SYMBOL_VALUE in find_pc_sect_line.

[RFC] Linux-specific ppc32 ABI

Re: [rfc] Make DWARF-2 "address size" explicit

[RFC] make handling of input path vs subfile path consistent

[rfc] mn10300: Account for call site optimizations when performing an inferior function call

Re: [rfc] Multiple process support in gdbserver

[rfc] Remove default_gcore_mach from gcore.c

[rfc] Replace DEPRECATED_STREQ

Re: [RFC] Support exec tracing on GNU/Linux and HP-UX

[RFC] testsuite/lib/pascal.exp: Handle cygwin path to windows path conversion

[RFC] win32-nat.c: Improve handling of 'set shell on'

[RFC] ||/&& placement

[RFC]: New test scrupt gdb_buildall.sh

[rfc][1/3] gdbserver bi-arch support: rename init_registers

[rfc][2/3] gdbserver bi-arch support: core s390x part

Re: [rfc][3/3] gdbserver bi-arch support: fix s390x partial register access

Re: [rfc][3/3] gdbserver bi-arch support: fix s390x partial register access

[rfc][3/3] gdbserver bi-arch support: fix s390x partial register access

Add native error to file transfer protocol error packet

arm_addr_bits_remove

Bug in mips:3900 arch ?

comment fixes in defs.h, target.c

DFP build failure

Re: expand-symtabs.exp

Re: GDB/libiberty support for IBM long double

generic code duplication in Ada files

generic/gdbtk-varobj.c: Adjust for varobj_list_children change

Helper functions in findvar.c predict current_gdbarch

Re: mi-var-child failures

Re: MI/CLI breakpoint handling code duplication

minor comment clarification (cut and paste fix)

MIPS: Handle manual calls of MIPS16 functions with a call stub

Need to update copyright year in sources & docs

New port cr16 - patch submission

Re: New scope checking patch

RE: Our next GDB release (GDB version 6.8)

PATCH: Update contact information

Re: Ping: Fortran dynamic arrays

Plotting from GDB

Re: PR 2343 fix: signal number mismatch

Re: Printing decimal128 types out of registers

Regressions on i686-pc-linux-gnu

remote protocol patch

Re: Remove deprecated_set_value_type

Remove deprecated_set_value_type (part 1)

RFA: Make sigthread.exp more reliable

RFA: mention gdb/gdbserver/README in gdb/README

Re: RFA: patch to fix multi-breakpoint enable/disable handling of inline functions

Re: RFA: Recognize 'unknown host' errors when connecting to gdbserver

Re: RFA: Recognize 'unknown host' errors when connecting to gdbserver

RFC: new command to search memory

skip __main


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc 2.6.3