This is the mail archive of the gdb-patches@sources.redhat.com mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [patch, rfc] frame attribute - FRAME_IS_CALLER


On Wed, Jul 09, 2003 at 04:04:03PM -0400, Andrew Cagney wrote:

Hello,

Ref: Add frame_is_callee_p(), use in dwarf2-frame.c?,
http://sources.redhat.com/ml/gdb-patches/2003-07/msg00046.html

This patch adds a new `frame attribute' methods and defines one attribute `FRAME_IS_CALLER' (described in comment) (again better name?).

It then uses it in a couple random places so that i know it is working.

thoughts,

The attached would be committed to the mainline, and just the new methods to the branch.

Andrew


Shouldn't FRAME_IS_CALLER only be true if THIS->type == NORMAL_FRAME &&
NEXT->type == NORMAL_FRAME?  If NEXT->type == NORMAL_FRAME but
THIS->type == DUMMY_FRAME, then NEXT's return PC shouldn't be
decremented, et cetera.

You mean, does a dummy frame `call' a normal frame? As far as the callee (the normal frame) is concerned, yes. It can't detect any thing different. It was called by the dummy frame.


The assert this->type != DUMMY_FRAME probably wouldn't hurt frame_address_in_block though - the function is meaningless for dummy frames.

Andrew



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]