gdb-patches archive
subject index for January, 2003

This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

(committed toplevel patch) Make rda native-only

(toplevel patch) Use canonical names for target_subdir, build_subdir.

Re: (toplevel) Fix dramatic breakage for ordinary crosses (related to program_transform_name)

[applied mips sim patch] add luxc1, suxc1.

[applied mips sim patch] check reserved instruction bits

[applied patch] update config.guess, config.sub to 2003-01-03.

[comit] Return unwound ID using a parameter

[commit/d10v] Don't check for dummy frames

[commit] Accessors for CFI's frame->context

[commit] Add --keep option to gdb_mbuild.sh

[commit] Allocate arm's prologe_cache at run time

[commit] ChangeLog -> ChangeLog-2002

[commit] Clean-up function declaration indentation

[commit] Coding cleanups

[commit] Constant propogate unpack_long(), arm-elf can be built with-Werror

[commit] Convert pop() to a per-frame method

[commit] DJGPP and free->xfree fixes

[commit] Do not require POP_FRAME method

[commit] Document remaining PTRs

[commit] Don't directly modify frame->frame

[commit] Don't require FRAME_INIT_SAVED_REGS

[commit] fix a compilation failure in hpread.c

[commit] fix a few incorrect cast warnings in hpread.c

[commit] fix a small compilation failure in alpha-tdep.c

[commit] Fix alpha linux with opaque frames

[commit] Fix HP/UX DO_REGISTERS_INFO typo

[commit] fix mn10300 tipo

Re: [commit] Fix sparc build; Was: [commit] fix a small compilation failure in alpha-tdep.c

[commit] Fix sparc build; Was: [commit] fix a small compilation failurein alpha-tdep.c

Re: [commit] Fix sparc build; Was: [commit] fix a small compilationfailure in alpha-tdep.c

[commit] frame_obstack_alloc() -> frame_obstack_zalloc()

[commit] Include "osabi.h" into x86-64-linux-tdep.c

[commit] ISO function definitions for sim/h8300/compile.c

[commit] More deprecated frame manipulation functions

[commit] PTR free zone

[commit] Random cleanups

[commit] Remove obsolete doco text

[commit] revamped gdb_mbuild.sh

[commit] Revert some of the yanked d10v pc in call dummy checks

[commit] Skip args test if target doesn't support args

[commit] Some easy cleanups

[commit] Update 2003 copyright on some files

[commit] Update d10v's extract / restore code

[commit] Use deprecated_set_frame_saved_regs / get_frame_saved_regs.

[commit] Use deprecated_update_frame_base_hack()

[commit] Use frame methods in i386 build

[commit] Use frame_relative_level() + bitrot comment

[commit] Use get_frame_base()

[commit] Use get_frame_extra_info()

[commit] Use get_frame_saved_regs(), mostly

[commit] Use get_next_frame()

[commit] Use method to update/allocate frame->extra_info

[commit] Use methods to manipulate frame->next / ->prev

[commit] Zap last remaining PRINT_REGISTER_HOOK

[commit] zap obsolete code from gdbserver/

[commit] Zap obsolete code segments

[DOC] --args?

[maint] Blanket Write Privs -> Global Maintainers

[maint] GDB expects indent 2.2.9'; Was: [patch/rfc] Update gdb_indent.shto version 2.2.9 ...

[mips sim patch] remove existing EI, DI from simulator?

[ob/doc] Fix how to allocate frame memory doco

[ob] Delete `just one or two' unused files

[ob] Delete mon960-rom.c

[ob] Eliminate deprecated complain()

[ob] Re-indent utils.c

[ob] Zap a stray `boolean'

[PATCH/commit] Fix fallout from until changes

[patch/obish] Use get_frame_pc() et.al.

[PATCH/RFA] cleanup 'srcfile' var usage

Re: [patch/rfc; rfa:doco] Add reggroups and their maint commands

[patch/rfc] Add a sentinel frame

[patch/rfc] Add frame unwinder registrary

[patch/rfc] Add predicates to FRAME_CHAIN() and FRAME_SAVED_PC()

[patch/rfc] Convert d10v to new frame mechanism

[patch/rfc] Eliminate char buf[MAX_REGISTER_RAW_SIZE]

[patch/rfc] Eliminate dummy frames before/after text end

[patch/rfc] Eliminate the es1800 target

[patch/rfc] Flush nindy fallout

[patch/rfc] KFAIL gdb.c++/annota2.exp watch triggered on a.x

[patch/rfc] Make `struct frame_info' opaque ish

[patch/rfc] More dynamic allocation of scratch `struct frame_info'

[patch/rfc] Obsolete h8500hms

[patch/rfc] Obsolete m32r

[patch/rfc] Obsolete the mn10200

[patch/rfc] Obsolete the z8k

[patch/rfc] post-process the `maint print architecture' from gdb_mbuild.sh

Re: [patch/rfc] post-process the `maint print architecture' fromgdb_mbuild.sh

Re: [patch/rfc] Remove all setup_xfail's from testsuite/gdb.mi/

Re: [patch/rfc] Revised gdb_mbuild.sh

[patch/rfc] Unwind the frame's PC first

[patch/rfc] Update gdb_indent.sh to version 2.2.9 ...

[patch] Add ChangeLog-2002 to config/djgpp/fnchange.lst

Re: [PATCH] Cleanup configure.in (1/n)

[PATCH] Cleanup configure.in (10/n)

[PATCH] Cleanup configure.in (11/n)

[PATCH] Cleanup configure.in (12/n)

[PATCH] Cleanup Configure.in (13/n)

[PATCH] Cleanup Configure.in (14/n)

[PATCH] Cleanup Configure.in (15/n)

[PATCH] Cleanup Configure.in (16/n)

[PATCH] Cleanup Configure.in (17/n)

[PATCH] Cleanup Configure.in (18/n)

[PATCH] Cleanup configure.in (3/n)

[PATCH] Cleanup configure.in (4/n)

[PATCH] Cleanup configure.in (5/n)

[PATCH] Cleanup configure.in (6/n)

[PATCH] Cleanup configure.in (7/n)

[PATCH] Cleanup configure.in (8/n)

[PATCH] Cleanup configure.in (9/n)

Re: [PATCH] Compare contents when evaluating an array watchpoint

[PATCH] Compile objc-lang.c objc-exp.tab.c

[PATCH] Delete stack.c redundant functions

Re: [PATCH] exec.c: print_section_info() format string fixes

Re: [Patch] Fix ABI incompatibilities on s390x

[PATCH] Get rid of configure scripts in testsuite subdirectories

[PATCH] Handle ObjC OPS in eval.c

Re: [PATCH] Integrate x86-64 and i386 targets

[patch] KFAIL hairyfunc5-7

[patch] kfail inherit.exp tests

[patch] linespec.c: normalize comments

[patch] linespec.c: rename 's' to 'file_symtab'

[patch] linespec.c: s -> file_symtab, again

[patch] lucid demangling XFAIL->KFAIL

Re: [patch] m32r-stub.c

[PATCH] Make i386_get_longjmp_target 64-bit safe

[PATCH] Make tests more flexible

[patch] Makefile.in Insight install

Re: [PATCH] mips-tdep.c: Fix bug introduced at time of NUM_REGS multiarch

[PATCH] obsolete cfront support

Re: [PATCH] readline warning fixes

[patch] README: remove references to deleted remote-*.c

Re: [PATCH] Rewrite testsuite/configure.in

[patch] sim/common/run.c: Fix typos in usage.

[PATCH] Step over Objective-C dispatch function

[PATCH] testsuite/gdb.base/miscexprs.c: fix array bounds violation

[patch] top.c: update banner copyright year

[patch] update linespec copyright

Re: [repost] Re: RFC: support debug info in separate files

Re: [rfa+testsuite] don't search off the end of partial symbol tables

Re: [RFA/breakpoint] Fix errors from disabled watchpoints

[RFA/doc] until/advance commands

Re: [rfa/doco] FRAME_FP -> read_fp

Re: [rfa/i386] Make codestream deprecated?

[RFA/PATCH] Behavior of gdb with -fullname and -interpreter=mi

Re: [RFA/PATCH] breakpoint.c: fix until command

[rfa/ping] lib/gdb.exp: remove LC_ALL=C workaround for readline bug

[RFA/testsuite] advance.exp/until.exp

[rfa/testsuite] gdb.mi/mi-pthreads.exp, gdb.mi/mi1-pthreads.exp: work with stripped libc

[rfa/testsuite] more selftest.exp tweaking

[RFA/testsuite] New test for --args

[RFA/testsuite] Re: RFC: gdb_test_multiple

Re: [RFA/testsuite] Suppress errors building thread tests

[rfa/toplevel] Conditionalize GDB_TK

[rfa:doc] Clarify stabs @

Re: [rfa?] Add frame_align(); Was: ARM stack alignment on hand called functions

Re: [rfa?] Add frame_align(); Was: ARM stack alignment on hand calledfunctions

Re: [RFA] (ping) GDB crash when using command lines due to memory corruption

[RFA] Add ObjC recognition to linespec.c [5/5]

Re: [RFA] Add support for 64-bit MIPS GNU/Linux targets

[rfa] ALL_OBJFILE_MSYMBOLS

[rfa] allocate_objfile(NULL, 0)

[RFA] Another optional underscore in testsuite

Re: [RFA] arm_extract_return_value, big-endian

Re: [RFA] Artifical dwarf2 debug info

[RFA] Compile objc-lang.c, objc-exp.tab.c [1/5]

Re: [rfa] delete duplicate definition of DEPRECATED_PC_IN_CALL_DUMMY

[rfa] delete macro SYMBOL_LINKAGE_NAME

[RFA] Demangle ObjC symbols in symtab.c [4/5]

[rfa] doc/gdbint.texinfo: update commands for release tarball

[RFA] Fix a "pc ... in psymtab but not in symtab" internal error warning

Re: [RFA] Fix a memory corruption in mdebugread.c

Re: [RFA] Fix a small memory leak in bpstat_stop_status

Re: [RFA] fix gdb/901 - attach to process running as service on Windows

[rfa] fix readline utf-8 display bug

Re: [RFA] Fix the spurious failures on H8/300 port.

[rfa] gdb.texinfo: new release tarball commands

[rfa] handle integer downsizing correctly in C++ overloading

[RFA] Kill some linear searches in minsyms.c

[rfa] lib/gdb.exp: remove LC_ALL=C workaround for readline bug

Re: [RFA] lin-lwp.c: more printf debugging

[rfa] linespec.c: decode_dollar

[rfa] linespec.c: decode_variable

[rfa] linespec.c: lookup_prefix_sym

[RFA] mips-tdep.c: Fix inferior function call breakage

Re: [RFA] New function type_code_name.

Re: [RFA] New variable, 'max-completion-results'.

[rfa] README, doc/gdb.texinfo: warn against '.../gdb-VERSION/gdb/configure'

[RFA] Register FORTRAN types with gdbarch_swap.

Re: [RFA] Relocate debug information in object files (e.g. add-symbol-file) [take 2]

[RFA] Replace SET_NAMESTRING macro by function in hpread.c

[RFA] Runtime Dwarf2 CFI engine cleanup

[RFA] sim/h8300/h8300.c: Fix the handling of bxor.

[RFA] Underscore tweak (old HP test)

[rfa] update config/djgpp/fnchange.lst with recent gdb.c++ files

Re: [RFA]: LOC_COMPUTED + abstracted dwarf2 evaluator, again

[RFC/RFA] New 'to' command

[RFC/testsuite] Update "info float" output for i386

[RFC] "maint print symbols" uses current language to print all symbols?

Re: [RFC] Correct gdbserver register packets

[rfc] gdb.c++/*.exp: remove CLLbs* references

[RFC] hppa/multiarch - PUSH_DUMMY_FRAME depends on inf_status

[RFC] lin-lwp.c prelim changes for new thread model

[RFC] Move ``length'' from struct main_type to struct type

Re: [RFC] Partial support for dwarf3 DW_AT_ranges

[RFC] Re: Profiling gdb?

[rfc] README, doc/gdb.texinfo: warn against '.../configure/gdb-N.N/gdb/configure'

[RFC] s390-tdep.c: Define address class functions for s390x

[RFC] trying to kill a warning in hpread.c (from call to complaint)

[RFC] Update to current automake/autoconf/libtool versions (take 2)

Re: [RFC] Update to current automake/autoconf/libtool versions (take2)

Re: [RFC] Update to current automake/autoconf/libtool versions(take 2)

Re: [RFC] Update to current automake/autoconf/libtool versions.

[RFC]: Minor clean up of variable names in infrun.c

[RFC]: win32-nat.c better handling of DLL relocation

[unwind-20030108-branch] Add sentinel-frame + misc

[unwind-20030108-branch] Convert d10v to unwind mechanims

[unwind-20030108-branch] Make certain that the duplicated PC's arein sync

[unwind-20030108-branch] Move legacy to legacy-frame.[hc]

[unwind-20030108-branch] Unwind the PC first

[unwind-20030108-branch] Work around get_frame_base()

alpha-linux access to thread unique value

Any pending testsuite, CLI patches?

Re: ARM PATCH fix extract_return_value and store_return_value

Beautify your school!

changes checked in mdebugread.c by mistake - reverted

changes for expect to build on IRIX 6

coffread.c extension for DLLs without debugging symbols

Deprecated breakdown

Email address change in Maintainers file

Fall back from Windows to Cygwin PIDs

Re: Fall back from Windows to cygwin PIDs

Fix a goof in the profiling code

Fortran: Intel vs G77

Re: gdb --args mishandles empty arguments

Re: GDB 5.2/5.3 breakpoint bug

Re: gdb-5.3 -- some minor build problems + 3 patches

gdb.asm/arm.inc tweak

gdb.c++ vs dos names

Re: gdb/849: no break line when stop at member function of a class

Hardware Watchpoint/Breakpoints and Remote Protocol

HP/UX 64 need CALL_DUMMY_LOCATION ON_STACK?

I reverted it.

Re: Incomplete last line, gdb/testsuite/gdb.hp/gdb.aCC/optimize.c

make info warnings

mi test fix for remote targets

Missing check for mbsrtowc causes compilation failure on HP/UX 11.11

Re: OC?

oprofile; Was: [RFA] Kill some linear searches in minsyms.c

RE: PATCH : H8300 Simulator File I/O Implementation

PATCH [mi-testsuite]: Use kfail in mi*-console.exp

PATCH/c++testsuite: Fix a missing (void|)

PATCH/testsuite: Enable two setup_kfails

PATCH/testsuite: Fix store.exp

PATCH/testsuite: Remove an XFAIL in virtfunc.exp

PATCH/testsuite: Remove extra xfails from constvars.exp

PATCH/testsuite: Use kfail for killed.exp

PATCH: --with-sysroot for GDB

PATCH: Add some BFD types to gdb_indent.sh

PATCH: clean up some filename handling in find_separate_debug_file

PATCH: doc fix to struct objfile

PATCH: Fix a regexp in gdb.c++/casts.exp test

PATCH: Fix openp() if the file doesn't exist

PATCH: Remove an error() in stabsread.c

Patches to improve Fortran support

Re: ptype bug RESEND

RFA [threads]: Fix print-threads.exp

RFA [threads]: Thread cache

RFA: Add SH2E support

Re: RFA: add testsuite function for answering internal error questions

RFA: always default to using the libiberty regex

Re: RFA: change for gdb/mi 495

RFA: Fix a big memory leak reading minimal symbols

RFA: Patch for corefile support

Re: RFA: Rename remote protocol's CRC function

Re: RFA[testsuite]: Fork event updates, part the fourteenth

Re: RFA[threads]: Fork event updates, part the fifteenth

Re: RFA[threads]: Fork event updates, part the thirteenth

Re: RFC/gdbarch: Make OS ABI a real member of the gdbarch

Re: RFC: "set osabi"

Re: RFC: Allow symbol_file_add to take section_offsets table

Re: RFC: allow syms_from_objfile to take a section offset table directly

RFC: C++ overloadin fixes and a type "char" tweak

RFC: Demangle partial symbols and save memory too

RFC: Flush frame cache in value_assign

Re: RFC: gdb.c++/main-falloff.exp (a new KFAIL)

RFC: gdb_test_multiple

Re: RFC: Mostly kill FRAME_CHAIN_VALID, add user knob

RFC: PowerPC/Linux signal handlers

Re: RFC: print better messages for separate debug info

Re: RFC: Slay COERCE_FLOAT_TO_DOUBLE

sim/arm/ChangeLog fixes

sim/arm/README patch

Re: sim/mips patch: add support for more NEC VR targets

Spurious testsuite failures due to multibyte locale

Re: subdir/toplevel dependence (was Re: (toplevel)...)

Submission of patches for Cobol support

Re: Sumbitting ip2k port for review.

symtab.c patch for pr 849

threads and target-function-calls

unified gcc and src config.if

Unreviewed PATCH: SH Simulator - MAC.L implementation and MAC.W correction

Unreviewed patches

Use TCL_CC_SEARCH_FLAGS, not TCL_LD_SEARCH_FLAGS

z8k sim breakage


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc 2.5.14