gdb-patches archive
subject index for November, 2002

This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

(committed) fix for stupid error in utils directory

(toplevel patch) Dependency tidy.

(toplevel patch) introduce extra_host_args

(toplevel patch) move gcc_version_trigger

(toplevel patch) Real targets for make.

(toplevel patch) Remove 'vault' targets

(toplevel) Add more dependencies

(toplevel) introduce host subdir configuration in Makefile

(toplevel) small reorg

5.3 branch frozen

[5.3 PATCH] Fix a typo in maint.c

[5.3 PATCH]: Fix TUI breaking gdb interpreters (mi)

[5.3/FYI] GDB build successes

Re: [Bug-dejagnu] [RFA:] DejaGNU patch: Change -I to -isystem for testsuite.

Re: [Bug-dejagnu] [RFA:] DejaGNU patch: Change -I to -isystem fortestsuite.

[commit, oops] New function pc_in_dummy_frame(pc)

[commit/sim] Fix v850 build; Was: [commit] Fix boolean fallout; Was:bye-bye boolean

[commit] A selected_frame -> get_selected_frame()

[commit] Comment get_selected_block()

[commit] Deprecate USE_GENERIC_DUMMY_FRAMES

[commit] Eliminate default_frame_address()

[commit] Eliminate get_current_block()

[commit] Fix boolean fallout; Was: bye-bye boolean

[commit] fix sim/mn10300 dependencies

[commit] Move find_frame_addr_in_frame_chain() to varobj.c

[commit] New method find_frame_sal()

[commit] Print the name of the float-format

[commit] Update "frame.h" commentry

[commited] Flush arm and mips of old non-generic dummy-frame code

[commited] Zap some of the deprecated_frame_in_dummy()

[committed] Eliminate GDB_TARGET_UNMASK_DISAS_PC and GDB_TARGET_MASK_DISAS_PC

[Committed] More fixes for m68k-linux

[committed] Move frame_relative_level() to frame.c

[drow-cplus-branch] handle namespace scope

[drow-cplus-branch] More type printer updates

[drow-cplus-branch] Update templates.exp

[drow-cplus-branch] v3 destructors

[Fwd: Re: [Fwd: Re: gdb/725: Crash using debug target and regcaches(in 5.3 branch?)]]

Re: [Fwd: Re: Copyright statement [was: Fix ABI incompatibilities on s390x]]

[Fwd: Re: gdb/780: Problem to debug a DLL]

[Head/5.3] Build failure on powerpc-aix-4.3.2

[in/5.3] Fix some more build warnings

[maint] Add Daniej Jacobowitz to global list

[maint] Drop h8500 from build list

[MI PATCH RFA]: make -var-list-children's CHILDREN result field a list

[ob] Don't set get_saved_register() in Arm

[patch / rfc / 5.3] Attempt N++ for gdb_realpath()

Re: [PATCH RFA/RFC] Address class support

Re: [PATCH RFA] Create new file mips-tdep.h

[patch rfc rfa:i386] Add i386 specific register groups

[patch rfc] signal_handler_caller -> get_frame_type()

[patch/5.3] Add $(DESTDIR) prefix

[patch/5.3] expect on IRIX 6.5

[patch/5.3] Fix 8.3 and invalid-char problems on 5.3 branch

[patch/5.3] Fix some of the POSIX problems

[patch/5.3] Re-fix some dos character problems

[patch/commit] Re-fix PC_IN_CALL_DUMMY()

[patch/igen] Only sort on format_name when merging

[PATCH/MI] testsuite:cleanup execution commands

[PATCH/RFA] Add detach after breakpoint test to attach.exp

[PATCH/RFA] Move _initialize_hppa_tdep to the end of file

Re: [patch/rfc; rfa:doco] Add reggroups and their maint commands

[patch/rfc; RFA:testsuite] Revamp store for lval_register and lval_reg_frame_relative

Re: [patch/rfc; RFA:testsuite] Revamp store for lval_register andlval_reg_frame_relative

[patch/rfc] Add frame_register(); GET_SAVED_REGISTER() is a predicate

[patch/rfc] Add get_selected_frame(), deprecate selected_frame global

Re: [patch/rfc] Add get_selected_frame(), deprecate selected_frameglobal

[patch/rfc] Always define PC_IN_CALL_DUMMY et.al.

[patch/rfc] Default FRAME_ARGS_ADDRESS et.al. to default_frame_address()

Re: [patch/rfc] Delete PRINT_REGISTER_HOOK

[patch/rfc] Deprecate most pc_in_call_dummy*() variants

[patch/rfc] Deprecate PC_IN_CALL_DUMMY

Re: [patch/rfc] Eliminate PRINT_REGISTER_HOOK from SPARC

[PATCH/RFC] faster language identification

[patch/rfc] FRAME_FP() -> get_frame_base()

[patch/rfc] frame_pc_unwind()

[PATCH/RFC] Get rid of deprectated_read_register_gen in i387-tdep.c

[PATCH/RFC] interpreters part 2: start up

[patch/rfc] Make `at entry point', `generic dummy frames' the default

Re: [patch/rfc] Make `at entry point', `generic dummy frames' thedefault

[patch/rfc] Overhaul regcache for {save,restore}_reggroup

[PATCH/RFC] Propagate 'regno' in value_subscript.

[patch/rfc] registers[] -> deprecated_registers[]

Re: [PATCH/RFC] TLS support part 3

[patch/rfc] Use reggroups to decide which registers to print

[patch/sim] Fix some compile problems

[patch/sim] IGEN to FSF

[patch/sim] Re-indent sim/igen/*

[patch] a few more frame_in_dummy's

[patch] Add comment about realpath(NULL)

[PATCH] add comment to event-loop.c

[patch] Add i386_sse_regnum_p() to x86-64-linux-nat..c; Was: [patch]Fix x86-64 build

[PATCH] Add multiarch initialization code for hppa targets

Re: [PATCH] Address FIXME in i386-tdep.c:i386_extract_struct_value_address

Re: [PATCH] Allow 'NULL' to i387_supply_fsave et. al.

Re: [PATCH] C++ Dwarf2 inner scope PR/789

[patch] code_ptr -> func_ptr.

Re: [PATCH] Compare contents when evaluating an array watchpoint

[PATCH] Correct pascal parser problem.

[patch] Create dummy-frame.h

[patch] Delete sigtramp_saved_pc()

[patch] Deprecate frame_in_dummy()

[patch] Deprecate generic_get_saved_register()

[patch] Deprecate read_register_bytes() / write_register_bytes()

[patch] Deprecate read_register_gen() / write_register_gen()

[patch] Deprecate register_valid[]

[patch] Deprecate registers_fetched()

[patch] dummy-frame cleanups

[PATCH] event-top.c mini MI merge

[patch] Expand comment about complain() replacement

[PATCH] findvar.c: re-enable TLS

[Patch] Fix ABI incompatibilities on s390x

Re: [patch] Fix build probs; change address_class* to pure multi-arch

[PATCH] Fix cygwin attach command

[patch] Fix default for reggroups :-(

[PATCH] Fix FDOFF_REGNUM usage in i387-tdep.c

[PATCH] Fix skip_quoted usage in objc-exp.y

[PATCH] Fix stray puts_filtered in i387-tdep.c

[PATCH] Fix testsuite for maint.c changes

[patch] Fix x86-64 build

[patch] frame.h cleanup

[PATCH] get rid of IS_FPU_CTRL_REGNUM in i386-tdep.h

[PATCH] Get rid of tm-i386v42mp.h

[patch] get_prev_frame() cleanups

[PATCH] Give message if dlopen(libthread_db) fails.

[PATCH] Make "info float|vector" error out when there are no registers

[patch] Make generic_unwind_get_saved_register() static

[patch] Mention what replaced the deprecated functions

[PATCH] mi-symbol-*

[patch] More copyright updates

[patch] Move frame code to frame.c (corollary to dummy-frame.[hc])

[PATCH] objc-lang cleanups

Re: [PATCH] Objective-C language support.

[patch] Only frame chain once ...

Re: [PATCH] plugin patch

Re: [PATCH] Print vector registers in natural format, not hex

Re: [PATCH] Redefine skip_quoted

[PATCH] Regenerated gdb/configure...

[patch] remove #include "disasm.h" from printcmd.c

[patch] Remove dead regcache functions

[patch] remove Tix

[PATCH] replace macro bodies in tm-hppa.h by function calls

[PATCH] Revamp legacy GNU/Linux i386 native support

[PATCH] skip_quoted (updated)

[PATCH] Some pascal parser enhancements

[PATCH] Switch to demangle ObjC symbols in maint.c

[PATCH] symtab.c: remove dead code

[PATCH] Use PT_IO ptrace request if available

Re: [PATCH] Use read_memory_unsigned_integer when reading to CORE_ADDR

[PATCH] Various DLL loading fixes for cygwin target

Re: [PATCH]: gdb/769 - segv fault on "info shared" on GDB 5.2.1 HPUX64 11.00

[PATCH]: Remove unnecessary m68hc11_register_byte/raw_size

Re: [revised PATCH RFC] DWARF2 CFA not equal frame_base issue

Re: [revised PATCH RFC] DWARF2 CFA not equal frame_base issue

[rfa+5.3] bug in my earlier DW_TAG_namespace patch

Re: [RFA/5.3] AiX: enable thread support only if libpthdebug is recent enough

[rfa/doco] FRAME_FP -> read_fp

[rfa/i386] FP_REGNUM_P() -> i386_fp_regnum_p() et.al.

[RFA/PATCH] Add new osabis enums for hppa

[RFA/PATCH] Darwin fixes for ltconfig, ltcf-c.sh

[RFA/PATCH] Detect osabi in hppa gdbarch init

Re: [RFA/Semi-obvious/5.3?] Fix compilation error in hppa-tdep.c

[rfa/testsuite] Don't display values in output of pc-fp.exp

Re: [RFA/testsuite] Handle MIPS in step-test.exp

[rfa/testsuite] Test GDB's ability to store values in registers

Re: [RFA/testsuite] Update selftest.exp

Re: [rfa?] Add frame_align(); Was: ARM stack alignment on hand called functions

Re: [rfa?] Add frame_align(); Was: ARM stack alignment on hand calledfunctions

Re: [rfa?] Add frame_align(); Was: ARM stack alignment on hand called functions

[rfa?] Add frame_align(); Was: ARM stack alignment on hand calledfunctions

[RFA] (second rev) broken build using bison-1.75

[RFA] add ada expression types to expression.h

[RFA] Add stabs entries for coalesced symbols.

[RFA] AiX: enable thread support only if libpthdebug is recent enough

Re: [RFA] AiX: enable thread support only if libpthdebug is recentenough

[RFA] arm_extract_return_value, big-endian

[RFA] arm_store_return_value, big-endian

[RFA] arm_store_return_value, big-endian (take 2)

Re: [rfa] clean up lookup_symbol_aux

[RFA] cli-out.c new function

Re: [RFA] Compare contents when evaluating an array watchpoint

[RFA] doc/Makefile.in install

[RFA] export i386_frameless_signal_p for interix

Re: [RFA] Fix an error in value_change_enclosing_type

Re: [RFA] Fix gdb/669 (fwd)

[RFA] Handle stack underflow in dbxread.c

[rfa] linespec.c, part 1

[rfa] linespec.c, part 2

[rfa] linespec.c, part 3

[rfa] linespec.c, part 4

[rfa] linespec.c, part 5

[rfa] lookup_symbol_aux_minsym

Re: [RFA] mi testsuite varobj support

[RFA] mmalloc Makefile patch

[RFA] New variable, 'max-completion-results'.

[rfa] search for fields of this correctly, PR gdb/804

[RFA] Testsuite fix for "info float" changes

[RFA] testsuite tweak for Arm big-endian

[RFA] Top level configury additions for RDA (3rd try)

[RFA] Update Darwin support in top-level configure.in

Re: [RFA] Use vfork in shell_escape

[RFA]: File-I/O patch

[RFA]: File-I/O patch, Documentation

[RFA]: File-I/O patch, testsuite

[RFA]: gdb-fileio.h, defining stuff shared between gdb and target

[RFC/PATCH] interpreters part 1: new files

Re: [RFC/RFA] Adding new files for Interix (take 3)

Re: [RFC/RFA] TLS support part 2

[RFC] broken build using bison-1.75

[rfc] clean up linespec.c

[RFC] Correct gdbserver register packets

[RFC] Display exact entered expression for watchpoints

[RFC] Obsolete testsuite/gdb.chill/chexp.exp

[RFC] Sort linetables in objfile_relocate.

[wanted] Test of GDB modifying a value in a register

[wip] gdb_ari.sh

ARM crt0.o: Add NULL to end of argv[]

Re: bfd target lists

Re: ChangeLog typo?

Design problem with min sym relocation?

Doco? (was: "Re: Problems running GDB-5.1.")

Fixing target m68k-linux

GDB ObjC plan (was: Re: [PATCH] Redefine skip_quoted)

gdbserver m68k-*-linux*

HPPA files naming convention...

HPPA multiarching plan

m68k-linux native broken

m68k_register_virtual_type

RE: PATCH : H8300 Simulator File I/O Implementation

Patch for bug 567 (sparc-sun-solaris2.8)

Re: Patch for gdb/mi 604

Re: Patch for gdb/mi 792

Re: Patch for gdb/mi problem 702

PATCH for Re: Problems with floatformat on Alpha

Re: PATCH RFA: Fix MI stack frame output for synthetic frames

PATCH/RFC: Bring lin-lwp performance back to the real world

PATCH: abstract section index initialization code

PATCH: Add SIZEOF_N_SECTION_OFFSETS macro

PATCH: always flush gdb_stdout after reading symbols

Patch: drop NEC v810 support

PATCH: dwarf2read.c: restore list_in_scope properly

PATCH: Fix gdbserver build on S/390

PATCH: Fix MI stack frame output for synthetic frames

PATCH: Fork event updates, part the first

PATCH: Fork event updates, part the second

PATCH: Fork event updates, part the third

PATCH: gdbserver for ARM/Linux + conditional branches

PATCH: In dwarf2read, restore local_symbols and param_symbols

PATCH: MI testsuite: fix function name in error message

PATCH: remove outdated comment

PATCH: Remove unnecessary zero-initializations

PATCH: SH Simulator - MAC.L implementation and MAC.W correction

Patch: top level config (AIX)

patches: config for m68k-apollo-bsd*, or not

PING [RFA] DWARF-2, static data members

Ping on Objc patches

Ping on two MI patches

please kindly get back to me

Proposed enhancement to RDA, the remote debug agent

Re: Proposed patch for gdb/mi 741

read_memory_integer -> read_memory_unsigned_integer

revamped gdb_mbuild.sh

Re: RFA/types: Clean up use of field bitsize

RFA: add function for answering internal error questions

RFA: add testsuite function for answering internal error questions

RFA: Allow set/display of e500 accumulator and status registers.

Re: RFA: change for gdb/mi 494

Re: RFA: change for gdb/mi 495

RFA: Check that `Local' is not in scope when it shouldn't be

Re: RFA: Delete CPLUS_MARKER

RFA: gdb/783 doc change

RFA: test macro expansion in presence of #line directives

RFA: testsuite: attach.exp: don't move executables to /tmp

RFA: testsuite: pass optimization flag in the proper way

RFA: Tolerate filenames present in symtabs but absent from macro info

Re: RFA: Tolerate filenames present in symtabs but absent from macroinfo

RFC: Allow symbol_file_add to take section_offsets table

RFC: allow syms_from_objfile to take a section offset table directly

Re: RFC: Keep 5 yr. old hack for MIPS16 on disassembler code

Re: RFC: Moving disassembler_command to cli land and using newerdisassembler code

RFC: support debug info in separate files

Re: sim/mips patch: add support for more NEC VR targets

Simulation of MIPS recip and rsqrt instructions

Single step vs. "tail recursion" optimization

Stand resume() on its head

Suggest obsoleting some of the HPPA ports

top level patch: even MORE autoconfiness

Top level: convert target module targets to autogen style

Toplevel patch: Autogenerate host module targets

Toplevel patch: Autogenerate Makefile targets 1 (do-*)

Toplevel patch: Autogenerate Makefile targets 2 (*-target-*)

Toplevel patch: Autogenerate Makefile targets 3 (*-build-*)

Toplevel patch: blow away dosrel

Toplevel patch: determine 'install'ed subdirs at configure time

toplevel patch: Let configure decide which targets to hit (1)

toplevel patch: most autoconfiness of variables

Toplevel patch: Remove EXTRA_TARGET_HOST hackery

Toplevel patches, currently on branch in gcc

Warning fix

Which HPPA targets do we still support?


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc 2.5.13