This is the mail archive of the gas2@sourceware.cygnus.com mailing list for the gas2 project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

binutils 2.9 powerpc-rtems breakage



I switched binutils 2.9 in my tree for gas-980314 and was unable to
complete a one-tree style build of binutils 2.9, egcs 1.0.2, and newlib
1.8.0.  The compilation aborted when trying to compile libgcc2.c for
_muldi3.  I cut the command down to the following:

/usr1/rtems/work/tools/build-powerpc-tools/gcc/xgcc \
  -B/usr1/rtems/work/tools/build-powerpc-tools/gcc/ -O2  -DCROSS_COMPILE \
  -DIN_GCC    -O2 -I./include   -g1 -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED \
  -fexceptions -Dinhibit_libc   -mlittle -mrelocatable-lib -mno-eabi \
  -mstrict-align -I. -I../../src/gcc -I../../src/gcc/config -DL_muldi3 \
      ../../src/gcc/libgcc2.c -c -v

which produces the following output:

Reading specs from /usr1/rtems/work/tools/build-powerpc-tools/gcc/specs
gcc version egcs-2.90.27 980315 (egcs-1.0.2 release)
 /usr1/rtems/work/tools/build-powerpc-tools/gcc/cpp -lang-c -v -I./include
-I. -I../../src/gcc -I../../src/gcc/config -isystem
/usr1/rtems/work/tools/build-powerpc-tools/gcc/include -undef -D__GNUC__=2
-D__GNUC_MINOR__=90 -DPPC -Drtems -D__rtems__ -D__PPC__ -D__rtems__
-D__rtems__ -D__PPC -D__rtems -Asystem(rtems) -Acpu(powerpc)
-Amachine(powerpc) -D__CHAR_UNSIGNED__ -D__OPTIMIZE__ -g1 -D_RELOCATABLE
-D_CALL_SYSV -D_LITTLE_ENDIAN -D__LITTLE_ENDIAN__ -Amachine(littleendian)
-D_ARCH_PPC -DCROSS_COMPILE -DIN_GCC -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED
-Dinhibit_libc -DL_muldi3 ../../src/gcc/libgcc2.c /tmp/cca06464.i
GNU CPP version egcs-2.90.27 980315 (egcs-1.0.2 release) (PowerPC
Embedded)
#include "..." search starts here:
#include <...> search starts here:
 include
 .
 ../../src/gcc
 ../../src/gcc/config
 /usr1/rtems/work/tools/build-powerpc-tools/gcc/include

/home/joel/egcs-1.0.2/powerpc-rtems/lib/gcc-lib/powerpc-rtems/egcs-2.90.27/include
 /home/joel/egcs-1.0.2/powerpc-rtems/powerpc-rtems/include
End of search list.
 /usr1/rtems/work/tools/build-powerpc-tools/gcc/cc1 /tmp/cca06464.i -quiet
-dumpbase libgcc2.c -mlittle -mrelocatable-lib -mno-eabi -mstrict-align
-g1 -O2 -O2 -version -fexceptions -o /tmp/cca06464.s
GNU C version egcs-2.90.27 980315 (egcs-1.0.2 release) (powerpc-rtems)
compiled by GNU C version 2.7.2.3.
 /usr1/rtems/work/tools/build-powerpc-tools/gcc/as -mppc -V -Qy
-mrelocatable-lib -mlittle -o libgcc2.o /tmp/cca06464.s
GNU assembler version 2.9 (powerpc-rtems), using BFD version 2.9
Assembler messages:
FATAL: Can't create libgcc2.o: Invalid bfd target

1 returned

I can produce a .s file using -s and then assemble that file with:

./as -mppc -V -Qy -mrelocatable-lib libgcc2.s

which indicates to me that somehow the rtems configuration lost support
for the -mlittle option.  powerpc-rtems should be identical to
powerpc-eabi if that trips anyone's memory.

Thanks.


--joel
Joel Sherrill                    Director of Research & Development
joel@OARcorp.com                 On-Line Applications Research
Ask me about RTEMS: a free RTOS  Huntsville AL 35805
   Support Available             (205) 722-9985