This is the mail archive of the mailing list for the eCos project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: ecos + lwip

Mandeep Sandhu wrote:
1.3.1 for eCos. Just copy all the files in the archive over the eCos
Hi Simon,

I tried building a new linux synth target with the lwip_sequential package
selected (using the ecos supplied i386-elf GCC).

You should probably try with the lasted i386-elf toolchain from eCosCentric, at least that's what I'm using for my tests here.

I ran into some errors when I try ti build the target.

First there was a missing bracket in
Line 413.

That should not happen!

After fixing that, I get a bunch of errors:

Wall -Wpointer-arith -Wstrict-prototypes -Wundef  -Wno-write-strings
-g -O2 -ffunction-sections -fdata-sections  -fno-exceptions
-fno-stack-protector -Wp,-MD,src/api/tcpip.tmp -o
error: expected ‘;’ before ‘info’
error: ‘info’ undeclared (first use in this function)
make[1]: *** [src/ecos/sio.o.d] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory
make: *** [build] Error 2
make: Leaving directory `/home/mandeep/ecos/lwip-131/lwip-131_build'

I'm sure this port compiles fine but somehow my build seems to be
missing something. I've checked and I have
the serialio.h file

Well there was actually a mistake. I did compile sio.c even when serial support is not needed (no SLIP or PPP). The warnings in socket.h should not matter, but I'll look into them.

$ find packages/ -name serialio.h

Headers in the eCos repository will not be found when compiling, only the headers which are copied over to your build tree are recognized.

Well I fixed the bug with sio.c

Here is the fixed release:

Copy all the archives files over the existing files in your eCos repository. Then use the following to build:

> mkdir testbuild
> cd testbuild
> ecosconfig new linux lwip_eth_sequential

Note: If you want to build with i386-elf toolchain you need to edit ecos.ecc and change the user_value for CYGBLD_GLOBAL_COMMAND_PREFIX from "" to "i386-elf"

> ecosconfig tree
> make
> make -C net/lwip_tcpip/current tests

If this does not compile without errors there is something wrong with your setup. What is your environment?


Before posting, please read the FAQ:
and search the list archive:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]