This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: sshd service will not start on Windows 7

On 1/29/2013 2:14 PM, misterblinky wrote:
I installed cygwin on my windows 7 64-bit machine with openSSH and openSSL,
nothing else.

I then install sshd via ssh-host-config. I have tried with privilege
separation and without it. The end result is the same: I cannot start sshd
as a service (via net start sshd). When I do, I get the message "The CYGWIN
sshd service could not be started."

The messages I've gotten in /var/log/sshd.log has varied. Most often, I've
gotten the message "/var/empty must be owned by root and not group or
world-writable". But I just did another clean install of cygwin and went
through the process again and there are no messages in sshd.log though the
server reports as usual that it cannot be started. (NOTE: I'm not suggesting
that the results change even though i go through the same steps -- I'm
trying different combinations of suggestions found on the web, sometimes
with slightly different results, but always with the sshd server not

I've removed and clean installed cygwin probably 30 times, trying different

Here are some more details:

In ssh-host-config interaction, I chose to create the privileged users
cyg_server. After installing, as expected cyg_server is the owner of these


Also, I changed permissions to /var/log and /var/log/sshd.log to 777 just to
ensure that access to this wasn't blocked. I also tried various options
(like chown-ing these to cyg_server).

The service is configured to run under .\cyg_server with the proper

I always install cygwin as "Administrator" and I open my cygwin console as

whoami gives me my windows login name as expected. However, NOT as expected
the "groups <my-id>" command doesn't say that I'm in the Administrator
group, which I am. It shows only "Domain Users". I've tried some workarounds
suggested for "Domain Users" and none have succeeded

I've worked at this for 3 days (!!) and now I'm just dizzy and need some
knowledgable help.

thanks in advance for your time/thoughts

-- View this message in context: Sent from the Cygwin list mailing list archive at

Problem reports:
Unsubscribe info:

Open Windows User Manager and check if cyg_server is in the Administrators group.
My sshd does not start without this privilege.
Also I get a better error message if I do "net start sshd".

Try it. Good luck.
-- Bernd

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]