This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: sh files

On 10/30/06, dubcek <> wrote:

Thanks Eric. Unfortunately, your remedy did not work. As I mentioned in my
original mail, all my .sh files were made under unix. But I tried d2u anyway
(you never know), but I got the same result.

What does a hex view of your shell script say the line ending are?

For example, I have a working script and my line endings are \x0A

My Windows-y scripts all have \x0D\x0A

You can try u2d, then d2u to see if that can clean up wonky line endings.

Here is an example of one of my unsophisticated .sh files; it was intended
to clean up after a latex session:
rm *.div *.aux *.log

rm is actually in your path, yes?

when I run the (this was the name I gave to it), I get the 'command
not found' error reply.

This is the same error you get when bash doesn't understand the line endings. What sort of mount (binary vs. text) are your shells scripts on?

What shell do you run? The stuff we are talking about is all bash.

You may also want to observe so you
can send the appropriate attachment to the list to give folks the
information they need to help you.


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]