This is the mail archive of the cygwin-xfree mailing list for the Cygwin XFree86 project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Unable to install X on 64-bit Windows 7 Premium


On Tue, Aug 10, 2010 at 15:12, Jon TURNEY <jon.turney@dronecode.org.uk> wrote:
> On 10/08/2010 00:19, Bob Kline wrote:
>>
>> I finally had to replace my ancient Windows XP box, and ended up with a
>> Windows 7 Home Premium 64-bit system. If I run setup.exe to install a
>> fresh
>> cygwin, it succeeds as long as I don't touch the X11 set, leaving it at
>> Default (which is to say, don't install anything in the set). If I change
>> Default to Install for X11, I get a dialog box which says:
>>
>> Cygwin Setup - Running postinstall scripts
>> Postinstall script errors
>> The following errors occured executing postinstall scripts
>> Package: gcc4-core
>> gcc4-core.sh exit code 126
>
> This one is already reported at [1], and the workaround given there,i.e.
>
> chmod 755 /usr/sbin/fix-libtool-scripts-for-latest-gcc-runtimes.sh
>
> and then run /etc/postinstall/gcc4-core.sh manually should work.
>

I've done exactly this, then tried to install some X stuff and got:

    Package: xinit
            xinit.sh exit code 8
    Package: No package
            xinit.sh exit code 8

Any help would be appreciated. Thanks,
--Dan

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]