This is the mail archive of the cygwin-xfree mailing list for the Cygwin XFree86 project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Questions for previous Cygwin/X maintainers

On Sun, 2006-04-23 at 21:56 -0500, Yaakov S (Cygwin Ports) wrote:
> I'm now trying to get XWin from xorg-server-1.0.2 running.  I got it to 
> build with a few minor patches, but it can't seem to find the fonts, 
> similar to the FAQ:
> I have all the fonts installed and have run mkfontdir, mkfontscale, and 
> fc-cache on the font directories.  I've even tried running /usr/bin/XWin 
> with the old /usr/X11R6/lib/X11/fonts directories (via -fp arg), but it 
> still can't find the fonts.
> 1) What are the bare minimum fonts required for running XWin?

afair "fixed" and "cursor" (cursor.pcf.gz) from lib/X11/fonts/misc.
"fixed" is an alias to

make sure you run these commands in the misc directory in this order:

mkfontdir (equals mkfontscale -b -s -l)

mkfontdir reuses some information created by mkfontscale to create the
entries for the scaleable fonts. 

> 2) Is mounting the fonts directory necessary?  On one machine, on which 
> xorg-x11-6.8.2 was the first version installed, there is no such mount, 
> and yet the old XWin runs.

This was an issue on textmode mounts which should have been fixed.
Otherwise link binmode.o to XWin.exe

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]