This is the mail archive of the mailing list for the crossgcc project.

See the CrossGCC FAQ for lots more information.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Crosstool-NG build produces all the tools except the compiler


I'm trying to build an m68k-unknown-elf toolchain that will run on a
Windows system.  I'm building it on openSUSE 11.2.

I've installed the mingw cross compiler on my openSUSE system and
created a crosstool-NG configuration for a Canadian cross:

  Build on openSUSE
  Host on  Windows
  Target   m68k

When I run crosstool-NG it shows the following systems:

> [EXTRA]  Dumping internal crosstool-NG configuration                            
> [EXTRA]    Building a toolchain for:                                            
> [EXTRA]      build  = x86_64-suse-linux                                         
> [EXTRA]      host   = i386-mingw32msvc                                          
> [EXTRA]      target = m68k-unknown-elf                                          

The host value (i386-mingw32msvc) is openSUSE's name for the mingw
compiler running on openSUSE.

The build "succeeds", but it doesn't build a C compiler.  Specifically
it builds the following executable files:


Note that it doesn't "fail" building the compiler: it never even tries.
 I've tried changing the build scripts a bit to get them to try to build
the compiler but so far that just causes the build to fail for other
reasons.  I haven't actually tested the created .exe's yet.

Does this make sense that it doesn't try to build the compiler?

Also note that this happens with the current release of crosstool-NG as
well as the code from the repository.


For unsubscribe information see

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]