This is the mail archive of the mailing list for the crossgcc project.

See the CrossGCC FAQ for lots more infromation.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: PowerPC Cross Help

Brendan Simon wrote:

> "J.K. Brown" wrote:
> > I still get the same error.  I have the assembler set up in the path when
> > I start cygwin, but I am beginning to think that the configuration or makefile
> > is not attaching the prefix to the "as" command when making.
> > I've been combing thru the files used for the make in order to try to find the
> > "as" command.
> Test the installation to make sure the correct assembler can be found.

 A very wise advice! Knowing how to 'debug the GCC installation' should be one 
of the first things to learn...

 GCC has nice options for this purpose, but unfortunately they aren't mentioned 
in those 'README.1ST' docs.

 The most important for all GNU-tools could be the option '--help'. The 
current GCC releases (since egcs-1.1) has it :

E:\usr\local\bin>gcc-ppc-eabi --help
Usage: gcc-ppc-eabi [options] file...
  --help                   Display this information
  (Use '-v --help' to display command line options of sub-processes)
  -dumpspecs               Display all of the built in spec strings
  -dumpversion             Display the version of the compiler
  -dumpmachine             Display the compiler's target processor
  -print-search-dirs       Display the directories in the compiler's search path
------  < clip > -------

 If one remembers the '--help', finding the '-print-search-dirs', which lists 
the directories where the 'cpp', 'cc1', 'as', 'ld' etc. will be searched, is 
easy. If the 'as' for the target is in the GCC 'programs' search path, it 
should be found, although one would use some own naming system (like having a 
copy of the 'ppc-eabi' target assembler as '/usr/local/bin/as-ppc-eabi').

 My complain would be that 'configure' doesn't set the search path for the 
other binutils ('ar', 'ranlib' and 'nm') to use the GCC search paths, but 
relies on the rigid '$target-toolname' naming convention. If one has only
one copies of the tools in $prefix/$target/bin, or links there to some combined 
binutils for many targets, they will not be found. Older GCC-sources 
searched them also from the binutils 'install' directory...

 Cheers, Kai

Want more information?  See the CrossGCC FAQ,
Want to unsubscribe? Send a note to

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]