This is the mail archive of the crossgcc@sourceware.cygnus.com mailing list for the crossgcc project.

See the CrossGCC FAQ for lots more infromation.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: PowerPC Cross Help


"J.K. Brown" wrote:

> > I'm now getting the "as: unrecognized option `-ppc'" error.  I removed
> a previous
> > installation I had on cygwin and new extracted a tar.gz file which
> included Insight.
> > Now powerpc-eabi-gcc gives me the same error you have.  I couldn't
> quite
> > workout why because the compiler was exactly the same as before.  I
> had copied
> > the archive from my Linux box and used WinZip to extract it to
> /usr/local/gcc on
> > my cygwin machine.  This seems to be the cause of my problem as I
> tried using
> > "tar zxvf cygwin-powerpc-eabi.tar.gz" and that fixed the problems.
> I'm not sure
> > what the differences are.  Maybe tar/gzip handle unix style ascii
> files where as
> > WinZip does not (or I guess it could be the other way around).  This
> still could be
> > binary mount problem/solution but I'm not sure.
> >
> > Brendan Simon.
>
> I was using Winzip, so I tried the tar command.  I still get the same
> error.  I have the assembler set up in the path when I start cygwin, but
> I am beginning to think that the configuration or makefile is not
> attaching the prefix to the "as" command when making.  I've been combing
> thru the files used for the make in order to try to find the "as"
> command.  I'm going to try a few other things before I give Linux a run
> with the compiler.  Ideally I need one for crossing from windows to
> powerpc, but at this point I'll take what I can get.

OK.  Lets start from the basics and try and figure out what is or is not
happening.
I think you said that you had configured binutils-2.9.1 and did a make, make
install.  This should install the binutils user executables in $prefix/bin.
(OOPS.  I hope I didn't advise you to set your PATH to $prefix/$target/bin in a
previous email.  I hope not.).  Test the installation to make sure the correct
assembler can be found.  Type "powerpc-linux-as --version" assuming your
configure has "--target=powerpc-linux" and "--program-prefix=powerpc-linux-".  If
it is installed properly you should get something like

    # powerpc-linux-as --version
    GNU assembler 2.9.1
    Copyright 1997 Free Software Foundation, Inc.
    This program is free software; you may redistribute it under the terms of
    the GNU General Public License.  This program has absolutely no warranty.
    This assembler was configured for a target of `powerpc-linux'.

Note the powerpc-linux in the last line.  This is what you want to see.  Do you
get this ?
If you do, then you should be able to continue with your egcs/gcc build as long
as you have the same prefix, target and program-prefix settings.

Brendan Simon.


------
Want more information?  See the CrossGCC FAQ, http://www.objsw.com/CrossGCC/
Want to unsubscribe? Send a note to crossgcc-unsubscribe@sourceware.cygnus.com


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]