This is the mail archive of the mailing list for the crossgcc project.

See the CrossGCC FAQ for lots more infromation.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

i586-pc-linux-gnu/sh-hitachi-hms cross won't build


I'm struggling to create an egcs-1.1.2 sh-hitachi-hms cross-compiler
virgin i586-pc-linux-gnu (RedHat 6.0) setup.  I've attached an excerpt
of the build process; it looks like the problem crops up during testing
of xgcc.

I've tried this with both 'make cross LANGUAGES="c c++"' and 'make all
install' (the latter per the crossgcc FAQ; the former worked for me in
the past), to no avail.

I've checked and re-checked that I built binutils 2.9.1 and egcs-1.1.2
with --target=sh-hitachi-hms, and the configure process appears to find
them properly.  Paths and so forth, including the existence of xgcc in
/usr/src/egcs-1.1.2/gcc/, all seem to check out as well.

I'm doing all of this as root

I even replaced the RH60 gcc with a native egcs that I built myself, and
which seems to work properly.  Still no go.

I'm stumped, although I recognize that my skills are somewhat limited at
this point.  Any suggestions?


make[2]: Entering directory
rm -rf *.o pic core errs \#* *.E a.out
rm -f needed.awk needed2.awk errors dummy needed-list config.h stamp-*
rm -f   stamp-picdir
rm -f *.a required-list tmpmulti.out
rm -f *~ Makefile config.status xhost-mkfrag TAGS multilib.out
make[2]: Leaving directory
creating cache ./config.cache
checking host system type... sh-hitachi-hms
checking build system type... i586-pc-linux-gnu
checking for sh-hitachi-hms-ar... sh-hitachi-hms-ar
checking for sh-hitachi-hms-ranlib... sh-hitachi-hms-ranlib
checking for gcc... /usr/src/egcs-1.1.2/gcc/xgcc
checking whether we are using GNU C... yes
checking whether /usr/src/egcs-1.1.2/gcc/xgcc -B/usr/src/egcs-1.1.2/gcc/
accepts -g... yes
checking for POSIXized ISC... no
checking for a BSD compatible install... /usr/bin/install -c
checking how to run the C preprocessor... /usr/src/egcs-1.1.2/gcc/xgcc
-B/usr/src/egcs-1.1.2/gcc/ -E
checking for sys/file.h... yes
checking for sys/param.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for unistd.h... yes
checking whether the C compiler (/usr/src/egcs-1.1.2/gcc/xgcc
-B/usr/src/egcs-1.1.2/gcc/ -g ) works... no
configure: error: installation or configuration problem: C compiler
cannot create executables.



William A. Gatliff
Senior Design Engineer
Komatsu Mining Systems
To teach is to learn.

Want more information?  See the CrossGCC FAQ,
Want to unsubscribe? Send a note to

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]