This is the mail archive of the mailing list for the crossgcc project.

See the CrossGCC FAQ for lots more infromation.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: PowerPC Cross Help

Brendan Simon wrote:

> "J.K. Brown" wrote:
> > > Are you builing on a Cygwin host or are you building on a Linux host
> > for a > cygwin-to-linux cross-compiler (ie. Canadian build) ?
> >
> > I'm trying cygwin right now.  I set the path to the binutilities in the
> > cygwin.bat file.  I tried the "export method", and still get the exact
> > same error.
> >
> > > In using EGCS-1.1.2, the make results in the following error:
> > >
> > > _muldi3
> > > as: unrecognized option `-ppc'
> > > make[3]: *** [libgcc2.a] Error 1
> > > make[2]: *** [stmp-multilib-sub] Error 2
> > > make[1]: *** [stmp-multilib] Error 1
> > > make: *** [cross] Error 2
> >
> > Jessica
> Mmm.  I've never built on a Cygwin host so I don't know of the specific
> problems involved.  You should also mail to the cygwin list for more
> expert advise.  I stuck to Linux for speed and knowing I would have less
> problems (in theory anyway).
> It might be something as simple as a binary mount or text mount setting.
> I think it is advisable to have all cygwin mounts as binary.  This reason
> is that not all the the GNU tools have been fully ported to cygwin and
> they get confused with the linefeed/carriage-return thingy.
> Brendan Simon.

I'm now getting the "as: unrecognized option `-ppc'" error.  I removed a
previous installation I had on cygwin and new extracted a tar.gz file which
included Insight.  Now powerpc-eabi-gcc gives me the same error you have.  I
couldn't quite workout why because the compiler was exactly the same as
before.  I had copied the archive from my Linux box and used WinZip to
extract it to /usr/local/gcc on my cygwin machine.  This seems to be the
cause of my problem as I tried using "tar zxvf cygwin-powerpc-eabi.tar.gz"
and that fixed the problems.  I'm not sure what the differences are.  Maybe
tar/gzip handle unix style ascii files where as WinZip does not (or I guess
it could be the other way around).  This still could be binary mount
problem/solution but I'm not sure.

Brendan Simon.

Want more information?  See the CrossGCC FAQ,
Want to unsubscribe? Send a note to

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]