This is the mail archive of the binutils@sourceware.org mailing list for the binutils project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] gold: Provide more failed archive member info in error message


On Tue, Dec 4, 2018 at 5:35 AM H.J. Lu <hjl.tools@gmail.com> wrote:
>
> On Tue, Dec 4, 2018 at 12:00 AM Cary Coutant <ccoutant@gmail.com> wrote:
> >
> > > +  bool plugin_failed = false;
> > >
> > >    if (is_elf_object(input_file, memoff, &ehdr, &read_size))
> > >      {
> > > @@ -716,12 +717,20 @@ Archive::get_elf_object_for_member(off_t off, bool* punconfigured)
> > >             delete obj;
> > >            return plugin_obj;
> > >          }
> > > +
> > > +      plugin_failed = true;
> >
> > An unclaimed file is not a plugin "failure". I'd prefer to name this
> > variable "unclaimed".
> >
>
> Like this?
>

I will check it in.


-- 
H.J.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]