binutils archive
subject index for November, 2017

This is the mail archive of the binutils@sourceware.org mailing list for the binutils project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

.option directive

Re: [Bug gas/22492] Incorrect note section alignment

[Commit]: Add debuglink support to objdump and readelf

[committed v7 1/3] BFD: Write Linux core PRSTATUS note into MIPS core file

[committed v7 2/3] BFD: Extract PID from MIPS core dump file

[committed v7 3/3] Add test for fetching TLS from core file

[committed, PATCH] ld: Reformat emultempl/elf32.em

[committed, PATCH] x86: Add tests for -n option of x86 assembler

[committed, PATCH] x86: Pass "%F%P:" to linker callback in case of error

[Committed] Fix a thinko with memmem return values

[GAS][AARCH64]Fix a typo for IP1 register alias.

[gold commit] Allow multiple .eh_frame sections per object file

[gold commit] Allow multiply-defined absolute symbols when they have the same value

[PATCH 0/2] x86: shrink main opcode table

Re: [PATCH 0/3] Fix issues with writing Linux core PRSTATUS note on MIPS o32, n32 and n64 into core file

[PATCH 0/3] x86: correct register operand handling

[PATCH 0/4] Generate text-only LOAD segment similar to GNU_RELRO

[PATCH 0/6] ld: Add "-z textonly" option to ELF linker

[PATCH 0/8] xtensa trampolines rework in gas

Re: [PATCH 1/2] aarch64: Remove AARCH64_FEATURE_F16 from AARCH64_ARCH_V8_2

[PATCH 1/2] x86: drop Vec_Disp8

[PATCH 1/3] x86: drop VEXI4_Fixup()

[PATCH 1/4] ld: Update phase_enum/relro_enum and add seg_align_type

RE: [PATCH 1/6] Enable Intel AVX512_VBMI2 instructions

[PATCH 1/6] ld: Add "-z textonly" option to ELF linker

[PATCH 1/8] gas: extract xg_relax_trampoline from xtensa_relax_frag

Re: [PATCH 2/2] Add option for Qualcomm Saphira part

[PATCH 2/2] x86: derive DispN from BaseIndex

[PATCH 2/3] x86: use correct register names

[PATCH 2/4] ld: Add fold_segment_align/fold_segment_relro_end/fold_segment_end

Re: [PATCH 2/6] Enable Intel GFNI instructions

[PATCH 2/6] ld: Add TEXT_SEGMENT_ALIGN/TEXT_SEGMENT_{RELRO_}END

[PATCH 2/8] gas: xtensa: extract jump assembling for trampolines

[PATCH 3/3] x86: ignore high register select bit(s) in 32- and 16-bit modes

[PATCH 3/4] ld: Add lang_size_relro_segment

Re: [PATCH 3/6] Enable Intel VAES instructions

[PATCH 3/6] ld: Create a new LOAD segment for text-only LOAD segment

[PATCH 3/8] gas: xtensa: reuse find_trampoline_seg

[PATCH 4/4] ld: Add ldlang_check_relro_region/update lang_find_relro_sections_1

[PATCH 4/6] ld/ppc/spu: Also set expld.textseg.phase to exp_seg_none

[PATCH 4/8] gas: xtensa: merge trampoline_frag into xtensa_frag_type

[PATCH 5/6] ld: Add tests for -z textonly

[PATCH 5/6] ld: Add tests for -z textonly and -z notextonly

[PATCH 5/8] gas: xtensa: rewrite xg_relax_trampoline

[PATCH 6/6] x86-64: Add tests for -z textonly -z max-page-size=0x1000

[PATCH 6/8] gas: xtensa: reuse trampoline placement code

[PATCH 7/8] gas: xtensa: implement trampoline coalescing

[PATCH 8/8] gas: xtensa: speed up find_trampoline_seg

[PATCH v2] arm: detect buggy binutils when in thumb2 mode

[PATCH v2] x86-64: always use unsigned 32-bit relocation for 32-bit addressing

[PATCH v2] x86-64: don't allow use of %axl as accumulator

[PATCH v2] x86: ignore high register select bit(s) in 32- and 16-bit modes

[PATCH v2] x86: reject further invalid AVX-512 masking constructs

[PATCH, GAS/ARM] Clarify relation between reg_expected_msgs and arm_reg_type

[PATCH, riscv] Compress loads/stores with implicit 0 offset.

[PATCH] [ARC] [COMMITTED] Update test pattern patching.

[PATCH] [ARC] Fix handling of ARCv2 H-register class.

[PATCH] [ARC] Force the disassam to use the hexadecimal number for printing

[PATCH] [ARC] Improve printing of pc-relative instructions.

[PATCH] [ARC] Sync opcode data base.

[PATCH] [GAS] [AArch64] Updated AArch64 docs for Armv8.4-a.

Re: [PATCH] [GOLD] Add plugin API for processing plugin-added input files

[PATCH] [PowerPC] Use consistent types for holding insns, etc.

[PATCH] [PRU]: Fix disassembly text for instructions with reloc

[PATCH] Add reference to implicit use in _bfd_elf_is_local_label_name.

[PATCH] arm: detect buggy binutils when in thumb2 mode

Fwd: [PATCH] arm: ensure symbol is a thumb symbol in new binutils

[PATCH] as: Align note section to 4 bytes

[PATCH] Check return value of bfd_new_link_order

[PATCH] ELF: Don't check DT_NEEDED for linker script defined symbols

[PATCH] ELF: Don't set non_ir_ref_regular in check_relocs

[PATCH] elf: Properly compute offsets of desc and next note

[PATCH] Exclude libmsvcrt and similar libraries from being autoexported from DLLs

[PATCH] Finish fixing riscv gas lns-common-1 failure, and lns-duplicate.

[PATCH] First part of fix for riscv gas lns-common-1 failure.

[PATCH] Fix build error with --enable-targets=all.

[PATCH] Fix error message typo.

[PATCH] Fix riscv binutils xfail for debug_ranges test.

[PATCH] Fix riscv dwarf2-10 gas testsuite failure.

[PATCH] Fix riscv g++ testsuite EH failures.

[PATCH] Fix riscv ld testsuite failure for compressed1d.

[PATCH] Fix riscv malloc error on small alignment after norvc.

Re: [PATCH] Fix strong_ref_weak_def.sh and dyn_weak_ref.sh when configured with --enabled-default-hash-style=gnu.

[PATCH] Fix typo in my MAINTAINERS file email address.

[PATCH] Fix vax/ns32k/mmix gas testsuite regression.

RE: [PATCH] FT32: support for FT32B processor - part 2/2

[PATCH] gas/arm64: don't emit stack pointer symbol table entries

[PATCH] gas/ia64: fix testsuite failures

Re: [PATCH] gold: Don't adjust local symbol values in relocatable link twice

[PATCH] gold: Don't rescan for undefined symbols in dynamic objects

Re: [PATCH] gold: Ignore definition from a dynamic object for __start/__stop

[PATCH] In x86 -n docs, mention that you need an explicit nop fill byte.

[PATCH] ix86/Intel: don't require memory operand size specifier for PTWRITE

[PATCH] ld: Add OTHER_PLT_SECTIONS

[PATCH] ld: Check if GNU property note section exists

[PATCH] ld: Remove PF_X from PT_PHDR segment

[PATCH] ld: Set non_ir_ref_regular if relocs are checked after opening all inputs

[PATCH] ld: Set non_ir_ref_regular on symbols referenced in regular objects

Re: [PATCH] microblaze: Check for indirect and warning symbols

[PATCH] PE: don't corrupt section flags when linking from ELF objects

[PATCH] readelf: Check alignment of note section

[PATCH] RISC-V: Add Jim Wilson as a maintainer, and clean up our entries

[PATCH] RISC-V: Add satp as an alias for sptbr

[PATCH] Riscv ld-elf/stab failure, and fake label cleanup.

[PATCH] Update docs on filling text with nops.

[PATCH] Update PR ld/21562 tests for underscore targets

[PATCH] x86-64/Intel: issue diagnostic for out of range displacement

[PATCH] x86-64: always use unsigned 32-bit relocation for 32-bit addressing

[PATCH] x86-64: don't allow use of %axl as accumulator

[PATCH] x86/Intel: don't mistake riz/eiz as base register

[PATCH] x86/Intel: don't report multiple errors for a single insn operand

[PATCH] x86/Intel: issue diagnostics for redundant segment override prefixes

[PATCH] x86: add disassembler support for XOP VPCOM* pseudo-ops

[PATCH] x86: add support for AVX-512 VPCMP*{B,W} pseudo-ops

[PATCH] x86: correct UDn

[PATCH] x86: don't default variable shift count insns to 8-bit operand size

[PATCH] x86: don't omit disambiguating suffixes from "fi*"

[PATCH] x86: fix AVX-512 16-bit addressing

[PATCH] x86: reject further invalid AVX-512 masking constructs

[PATCH] x86: Remove func_pointer_refcount

[PATCH] x86: string insns don't allow displacements

[PATCH] x86: {f,}xsave64 / {f,}xrstor64 / xsaveopt64 should not allow q suffix

[PATCH][GAS][AArch64] Add new command-line options and macros for Armv8.4-a [Patch (2/6)]

[PATCH][GAS][AArch64] Add new encoding type macros for Armv8.4-a [Patch (3/6)]

[PATCH][GAS][AArch64] Add new fields and operands required for Armv8.4-a [Patch (1/6)]

[PATCH][GAS][AArch64] Add new instructions for Armv8.4-a [Patch (4/6)]

[PATCH][GAS][AArch64] Add new registers for Armv8.4-a [Patch (5/6)]

[PATCH][GAS][AArch64] Correctly add SIMD and FP dependencies to Crypto options.

[PATCH][GAS][AArch64] Enable Dot Product by default for ARMv8.4-a. [Patch (6/6)]

[PATCH][GAS][AArch64] Move new FP16 instructions to new flag

[PATCH][GAS][AArch64] Retroactively split CRYPTO into AES and SHA2.

[PATCH][GAS][ARM] Add Dot Product Extension as mandatory feature on Armv8.4-A [Patch (2/3)]

[PATCH][GAS][ARM] Assembeler and disassembler support for new FP16 instructions [Patch (3/3)]

[PATCH][GAS][ARM] Command line support for -march=armv8.4-a [Patch (1/3)]

[PATCH][GAS][ARM] Enable dot product support by default to cores that support it.

[PATCH][GAS][ARM] Move new FP16 instructions to new flag

[PATCH][GOLD] Fix PR0765 [2.27 Regression] gold internal error in fix_errata on aarch64-linux-gnu

Re: [PATCH][GOLD] Fix PR20765 [2.27 Regression] gold internal error in fix_errata on aarch64-linux-gnu

[PATCH][GOLD] Fix PR22233 gold segfault in relocate_erratum_stub on aarch64-linux-gnu

[PATCH][GOLD] gold aarch64 erratum stubs are created but not always applied

[PATCH][MIPS] Add Global INValidate instructions

[PATCH][MIPS] CRC ASE support

[PATCH][PR ld/22263] aarch64: Avoid dynamic TLS relocs in PIE

[PATCH][PR ld/22269] aarch64: Handle local undefined weak symbols

Re: [patches] Re: [PATCH] RISC-V: Add Jim Wilson as a maintainer, and clean up our entries

[PUSHED] opcodes/arc: Fix incorrect insn_class for some nps insns

Re: [Translation-i18n] xtensa message pluralization

Add NULL bfd test to elf_symbol_from

Adding support for `cat a.out | size -`

binutils: symbolic instead of hard links for the utilities

Building MinGW version of Binutils for Cross-Compilation

bundle_lock message tidy

Commit: Add ability to follow dwo links to readelf & objdump

Commit: Always create a padding buffer in sec_merge_emit

Commit: PR 22508: Objdump: check reloc count before allocating memory.

Commit: PR 22509: Check for a NULL symbol pointer when reading COFF relocs

Commit: PR 22510: Check for an absence of section headers when loading debug sections

Copying symbol type in ld script assignments

Delete powerpc64 symbol weakref field

Don't move weak alias dyn_relocs to weakdef

Re: First-time binutils repository code-stare - indentation and contribution process

Fix testcase for PR ld/22471

FYI - git-hooks updates to be deployed

gas and ld pluralization fixes

gold linker: rejected multiple definitions with the same absolute value

gold patch RFC: fix address size of DW_FORM_ref_addr

Handle ' and I format flags

Holiday for 4

hppa-linux TLS relocs

Inconsistent .eh_frame_hdr on powerpc64

ld einfo positional arg support

ld-ifunc non-PIC tests

lm32 fdpic toolchain segfault with binutils ld

mingw gas testsuite fix

New Chinese (simplified) PO file for 'opcodes' (version 2.28.90)

New gas testsuite failures

Re: New gold plugin interface for getting --wrap symbols

New regressions in GAS testsuite for arm-wince-pe

ngettext support

non_got_ref after adjust_dynamic_relocs

objcopy memory leak

optimal encoding of SIMD insns

PATCH] Properly handle note sections and segments

PowerPC readonly_dynrelocs

powerpc TLS in PIEs

PowerPC64 statistics message

PR22374 testcase, function pointer references in .data

PR22374, PowerPC unnecessary PLT entries

PR22394, hppa-linux-ld fails to emit dynamic relocations

PR22397, BFD internal error when message locale isn't C

PR22431, powerpc64 ld segfault when .plt discarded

PR22443, Global buffer overflow in _bfd_elf_get_symbol_version_string

PR22451, strip no longer works on older object files

PR22533, dynamic relocs generated for weak aliases

Re: Proposed patch to release 2.29.1 regarding --localedir configure option

readability improvements to i386-opc.tbl

readelf ngettext fixes

Rename u.weakdef and make it a circular list

Require ngettext in test of system gettext implementation

Re: RFA: ELF: Call check_relocs after opening all inputs

RFC: ELF: Add a "-z readonly" option to ld

rtld: resolve incoming STT_GNU_IFUNC only after DT_INIT

testsuite regressions on the trunk compared to the 2.29 branch (hppa, s390x)

Tidy elf.exp

weakdef list handling

Re: x86: AT&T syntax operand size defaults

xtensa message pluralization


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc