binutils archive
subject index for February, 2015

This is the mail archive of the binutils@sourceware.org mailing list for the binutils project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

[AArch64][gas] Fix code formatting in the cpu-table

[AArch64][gas][2.25] Backport code formatting fix in the cpu-table

[AArch64][gas][2.25] Backport support for Cortex-A72

[ARM][gas][2.25] Backport support for Cortex-A72

Re: [binutils-gdb] Fix memory access violations triggered by running addr2line on fuzzed binaries.

[commited,PATCH] Set root.linker_def on _TLS_MODULE_BASE_

[committed, PATCH] [gold] Replace two_file_shared_2.so with two_file_shared_1.so

[committed, PATCH] Add --[no-]map-whole-files for gold compatibility

[committed, PATCH] Add a testcase for PR ld/14918

[committed, PATCH] Check format against bfd_object directly

[committed, PATCH] Close fd only if fd != -1

[committed, PATCH] Convert mov to lea only if needed

[committed, PATCH] Document -z text, -z notext and -z textoff

[committed, PATCH] Don't bfd_check_format if not needed

[committed, PATCH] Output "warning:" or "error:" in plugin messages

[committed, PATCH] PR ld/17935: -z text should provide more info

[committed, PATCH] Use mmap and cache the view buffer for get_view

[Committed] [AArch64] Add tiny memory model GD test cases.

[Committed] Regenerate bfd-in2.h and libbfd.h

[Committed][AArch64] Add ADR :tlsgd: directive and TLSGD_ADR_PREL21 support.

[Committed][AArch64] Add support for :tlsdesc: and TLSDESC_ADR_PREL21

Re: [Committed][AArch64] Add support for :tlsdesc: and TLSDESC_ADR_PREL21

[Committed][AArch64] Add support for :tlsdesc: and TLSDESC_LD_PREL19

[Committed][AArch64] Add test case for ADR :got:foo

[Committed][AArch64] Add tiny DESC test cases.

[Committed][AArch64] Adding adr_type and prevent adr :got:

[Committed][AArch64] Adding ld_literal_type.

[Committed][AArch64] Adding support for TLSIE_LD_GOTTREL_PREL19.

[Committed][AArch64] Adding test case for abuse of :got: in offset load.

[Committed][AArch64] Adding tls-tiny-ie test.

[Committed][AArch64] Fix field size for TLSDESC_CALL

[Committed][AArch64] Fix field size for TLSLE_MOVW_TPREL_*, relocations.

[Committed][AArch64] Fix TLSIE_MOVW_GOTTPREL_G0_NC field size.

[Committed][AArch64] Remove dead code.

[g]make test and building with Clang

[gold commit] (PR gold/16992) Fix --dynamic-list so that symbols not in the list are still exported

[gold commit] Add more debug output for files and descriptors

[gold commit] Fix bug with previous patch for unresolved TLS symbol

[gold patch ob] PR gold/17971: Remove redundant include

[gold][aarch64]Patch to add support for TLSLE_MOVW_* relocations

[gold][patch] Avoid looking up Input_merge_map multiple times

Re: [Newbie question] compilation,, linking and general libbfd/libiberty question

[PATCH 0/2] Add --update-section option to objcopy.

[PATCH 0/2] PR ld/17878: Merge linker plugin handling into BFD plugin support

Re: [PATCH 0/3] AVR linker relaxation org/align support

[PATCH 0/8] PR ld/17878: Add and use bfd_maybe_object_p

[PATCH 08/36] elf-bfd.h: Wrap in extern "C".

[PATCH 1/2] Merge linker plugin handling into BFD plugin support

[PATCH 1/2] objcopy: Factor out some of the option parsing code.

[PATCH 1/8] PR ld/17878: Add bfd_maybe_object_p

[PATCH 2/2] Add tests for non-object IR file

[PATCH 2/2] objcopy: Add --update-section option.

[PATCH 2/8] PR ld/17878: Use bfd_maybe_object_p in linker.c

[PATCH 3/8] PR ld/17878: Use bfd_maybe_object_p in elf64-ia64-vms.c

[PATCH 4/8] PR ld/17878: Use bfd_maybe_object_p in vms-alpha.c

[PATCH 5/8] PR ld/17878: Use bfd_maybe_object_p in vms-lib.c

[PATCH 6/8] PR ld/17878: Use bfd_maybe_object_p in xcofflink.c

[PATCH 7/8] PR ld/17878: Use bfd_maybe_object_p in ecoff.c

[PATCH 8/8] PR ld/17878: Use bfd_maybe_object_p in coff-rs6000.c

RE: [PATCH RFC v2 24/70] MIPS: asm: spinlock: Replace sub instruction with addiu

[PATCH v2] Wrap BFD headers in extern "C"

Re: [Patch, ARM]Update the usages of Tag_ABI_HardFP_use per the latest EABI

[Patch, avr] Use symbols for MEMORY region lengths if available

[PATCH, FT32] Place ctors/dtors in RAM

[PATCH, nds32] Add one more argument to control contents cache.

[Patch/ARM] Skip private symbol when doing objdump

[patch/rfc][pr17902] GC unused parts of mergeable sections

[PATCH] [gold] Do not attempt to merge sections with an entsize of 0.

[PATCH] [gold] Recognize DWARF5/GCC5 DW_LANG_Fortran03 and DW_LANG_Fortran08.

[PATCH] [gold] Resolve forwarding symbols when computing symbol resolution info for plugins.

Re: [PATCH] [gold] Unlock external members of thin archives.

Re: [PATCH] add a configure option for using RELRO by default

Re: [PATCH] bfd/elfnn-aarch64.c: Set st_value to zero for undefined symbols

[PATCH] bfd: Avoid incrementing uninitialized variable

[PATCH] binutils: readelf: add missing newline to warning message

[PATCH] Enable building GDB without installed libtermcap

[PATCH] Fix an internal error in do_print_to_mapfile seen with gold on arm

RE: [Patch] Gas support for MIPS Compact EH

[PATCH] gas: fix a few omissions in .cfi_label handling

[PATCH] gold/arm.cc: Output mapping symbol for PLT code

[PATCH] PR bootstrap/65176: config.guess failed to guess machine with 64-bit kernel and 32-bit user space

[PATCH] PR gold/17640

Re: [PATCH] PR gold/17729: [gold] gold failed to build x32 libgo

[PATCH] PR ld/17973: Don't generate the fake FILE symbol when plugin is used

[PATCH] PR ld/17975: Useless FILE entry in symbol table for linker generated symbols

[PATCH] readelf: handle corrupted chains better

[PATCH] Recognize new DWARF5/GCC5 DW_LANG constants for Fortran 03 and Fortran 08.

[patch] Refactor duplicated code into a helper function

[PATCH] S390: Support new vector register sections

Re: [PATCH] sim: Be sure of calling freeargv() after successfully call buildargv().

[patch] Simplify Garbage_collection::add_reference a bit

[PATCH] Wrap a few opcodes headers in extern "C" for C++

[PATCH][ARM][gas] Use as_tsktsk instead of as_warn for deprecation messages

Re: [PATCH][ARM][gas] Warn on deprecated ldm r<n>, {..., sp,...} and ldm r<n>, {...,lr,pc,...} forms

[PATCH][gas][AArch64] Add support for Cortex-A72

[PATCH][gas][ARM] Add support for Cortex-A72

[PATCH][gas][ARM] Document supported ARMv8 cores

[patch][gold] Don't copy a std::vector.

[patch][gold] Remove empty Merge_map class

[patch][gold] Use std::upper_bound to simplify code a bit

[pr/17940] bfd/dwarf2.c: fix overflow bug in .dwarf_line

Re: [RFA] Add --with-libz-prefix option in config/zlib.m4

[RFC] objcopy: Add --update-section option.

Re: [RL78]: Objdump does not insert space between two operands in disassembly view.

[SH] Correct clrs,sets,pref insns

[v850] increase minimum alignment

Add aligned string merge test

Re: Allow pie links to create PLT entries

Fwd: ANNOUNCEMENT: Intel386 psABI version 1.0

Re: aout target fails

backports to 2.25 branch

Re: binutils write access

binutils write access (was: [SH] Correct clrs,sets,pref insns)

binutils/dwarf.c white space

buffer overrun in verilog bfd backend

Commit: Fix bug in pdp11's parsing of external symbols

Commit: MSP430 sim: Fix detection of illegal memory accesses

Commit: objdump: Improve failed to read section warning message

Commit: RL78 gas: Fix encoding of addw/subw instructions

Commit: RL78 gas: Fix use of uninitialised memory

Commit: RL78: Fix disassembling of [HL+0] addressing

Commit: V850 SIM: Add support for e3v5 instructions

Commit: V850: Add support for using notes

Re: Compressed exec and core files

Contributing FreeBSD/aarch64 support

Re: Copying .group sections using BFD

Correct ld.texinfo cross reference

Do weak variables waste mem?

Don't refer to optarg in dwarf.c function

Don't segfault or assert on NULL tls_sec

Drop undefined local symbols from symtab?

elflink.c whitespace, formatting and a plugin symbol tweak

fix dbb3fbbb dwarf2.c breakage

Fix gold error: hidden symbol '...' is not defined locally

Fix msp430 build with gcc-5

gas doc warning fixes

Gold testsuite fails with gcc-5

Gold testsuite make clean

Is it normal that ld promote a section size

Re: linker and debug section question

Pad only text sections at end by default

Re: PATCH: Compress debug sections for Linux/x86 by default

PATCH: NEWS: Mention support for LLVM plugin

Re: PATCH: PR ld/14272: Mark the plugin symbol undefined

PATCH: Remove unused dump_tv_tag

ping #3: [RFA] Add --with-libz-prefix option in config/zlib.m4

Ping [PATCH, h8300] Add h8300-*-linux

ping [was: Slow readelf for huge ARM binary]

ping^2: [RFA] Add --with-libz-prefix option in config/zlib.m4

PowerPC64 GOLD: complain on misaligned _DS relocs

PowerPC64 thread-safe stubs not needed for iplt

Problem caused by removed function and its remaining dwarf entry

Regressions in gas test-suite results with your recent dwarf fixes

RFC: [PATCH] PR ld/17878: Add plugin_input_file_t

RFC: [PATCH] PR ld/18028: 32-bit ld runs out of memory when linking 32-bit clang with debug info

RFC: [PATCH] Support -plugin-opt=disable-output for LLVM plugin

Slow readelf for huge ARM binary

tidy _bfd_elf_define_linkage_sym

Tweak ppc32 tls_get_addr optimisation

Use dynamic text relocs for protected vars

Re: wcsncasecmp undefined up to Mac OS X 10.7

xlc -z relro toc section fixes


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc