This is the mail archive of the mailing list for the binutils project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Make no-copy-dt-needed default?


what do people think about switching the default for 
add_DT_NEEDED_for_dynamic to false, i.e. make --no-copy-dt-needed-entries 
the default for GNU ld?

The linux distros Fedora, Debian and Ubuntu already do that with local 
patches, openSUSE is going to follow suit, and AFAIK gold has the same 
behaviour (without the possibility to change it).  It potentially can 
cause some minor hickups with current build systems, exactly in those 
cases where people relied on other libraries being included via recursive 
DT_NEEDED instead of listing the dependencies in the link editing command, 
i.e. in cases that would break already right now with static archives.

As Fedora and Debian are using this switched default already for some
time I'd expect most projects with an active upstream would be fixed 
meanwhile.  A good summary of what exactly is implied by such a change is 
e.g. at .

I realize that just because some random linux distros are doing something 
shouldn't necessarily imply a change in upstream binutils, but in this 
case I think it makes sense.

So, should I propose a patch?


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]