This is the mail archive of the mailing list for the binutils project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: binary to elf conversion

On Thu, Aug 16, 2007 at 09:55:29AM -0500, Joel Sherrill wrote:
> Hi,
> I think something broke for converting binary
> files to elf using objcopy.  I know I did this before
> but can't seem to find a binutils that can do
> this now.  I have tried both the RTEMS testing
> version (a pre 2.18 snapshot) and our
> stable repositories (something older)
> and neither is able to link with the object file produced by objcopy'ing
> a binary file  to a .o.
> /opt/rtems-4.8/lib/gcc/powerpc-rtems4.8/4.2.1/../../../../powerpc-rtems4.8/bin/ld: 
> unknown architecture of input file `o-optimize/tarfile.o' is incompatible 
> with powerpc:common output
> Produced by this command:
> powerpc-rtems4.8-objcopy -I binary -O elf32-powerpc tarfile 
> o-optimize/tarfile.o
> I tried mips and i386 and both fail with similar errors.
> Is this working for anyone else on any target?

[hjl@gnu-6 tmp]$ file x
x: ASCII English text
[hjl@gnu-6 tmp]$ objcopy --version  -I binary -O elf32-i386 x y
GNU objcopy (Linux/GNU Binutils)
[hjl@gnu-6 tmp]$ file y
y: ELF 32-bit LSB relocatable, no machine, version 1 (SYSV), not stripped
[hjl@gnu-6 tmp]$


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]