This is the mail archive of the mailing list for the binutils project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: binutils/glibc .hashvals section ...

Hi Nick,

On Fri, 2006-01-27 at 17:51 +0000, Nick Clifton wrote:
> There is no reason why such a patch cannot be included in binutils. 
> People are free to modify glibc after all.

	Ok; that's encouraging.

> > +	    case DT_SUSE_HASHVALS: name = "SUSE_HASHVALS"; break;
> I assume that this feature does not have to be specific to SUSE, so I 
> would suggest a more generic name, eg DT_GNU_HASHVALS.

	No of course not; however - in an effort not to tread on namespaces
other people 'own', and for which the allocation authority is unclear; I
plumped for such suse-isms. Using GNU instead would be perfect.

> If the name of the section is going to be fixed 
> however then it ought to be specified as a #defined constant in a header 

	Fair enough - easy to fix.

> Other than that though the binutils part of the patch looks fine to me. 
>   A few formatting tidy ups and replacements of fprintf with calls to 
> bfd_error_handler, but otherwise OK.

	Sure - I just got a metric bus-load of formatting / stylistic feedback
from Andreas Schwab that I'll work through too.



--  <><, Pseudo Engineer, itinerant idiot

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]