This is the mail archive of the mailing list for the binutils project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Error building binutils from cvs

Hi  ... 

On Tue, Dec 17, 2002 at 05:59:24PM +0000, Nick Clifton wrote:
>> I tried to build binutils from CVS with --target=mips64-linux
>> --prefix=$PREFIX and I got this:
>> Configuring multilibs for libiberty
>> make: *** [mips64-linux/libiberty/multilib.out] Error 127
>I tried to reproduce this but failed - the configure and build worked
>correctly.  There have been a lot of changes to binutil's configure
>system over the last few weeks though, so they may have fixed the
>problem.  Please could you try again with the latest CVS sources and
>report if you still have a problem.

Not either  ... I have another problem here:

make[1]: Leaving directory `/mnt/develop/toolchain/compiled/binutils'
Configuring in mips64-linux/libiberty
loading cache ../config.cache
checking whether to enable maintainer-specific portions of Makefiles... no
checking for makeinfo... makeinfo
checking for perl... perl
checking host system type... mips64-unknown-linux-gnu
checking build system type... powerpc-unknown-linux-gnu
checking for mips64-linux-ar... /mnt/develop/toolchain/compiled/binutils/binutils/ar
checking for mips64-linux-ranlib... /mnt/develop/toolchain/compiled/binutils/binutils/ranlib
checking for gcc...  mips64-linux-gcc -L/mnt/develop/toolchain/compiled/binutils/ld
checking whether we are using GNU C... no
checking whether  mips64-linux-gcc -L/mnt/develop/toolchain/compiled/binutils/ld and cc understand -c and -o together... no
checking for POSIXized ISC... no
checking for working const... no
checking for inline... no
checking for a BSD compatible install... /usr/bin/install -c
xhost-mkfrag is unchanged
checking how to run the C preprocessor... /lib/cpp
checking for sys/file.h... yes
checking for sys/param.h... yes
checking for limits.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for unistd.h... yes
checking for strings.h... yes
checking for sys/time.h... yes
checking for time.h... yes
checking for sys/resource.h... yes
checking for sys/stat.h... yes
checking for sys/mman.h... yes
checking for fcntl.h... yes
checking for alloca.h... yes
checking for sys/wait.h that is POSIX.1 compatible... no
checking whether time.h and sys/time.h may both be included... no
checking whether errno must be declared... yes
checking for ANSI C header files... no
checking for uintptr_t... no
checking for pid_t... yes
checking whether the C compiler ( mips64-linux-gcc -L/mnt/develop/toolchain/compiled/binutils/ld -O2 -g ) works... no
configure: error: installation or configuration problem: C compiler
cannot create executables.
make: *** [mips64-linux/libiberty/Makefile] Error 1

I tried to build the cross binutils from today cvs on intel to
mips64-linux and from powerpc to mips64-linux ......

I looked for mips64-linux-gcc and I did not found it ... 

	What is going wrong here?


  .''`.    Jan-Hendrik Palic     |
 : :' : ** Debian GNU/ Linux **  |   ** **       ,.. ,..
 `. `'   |  ,: ..`   `
   `- |                           '  `  `

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]