This is the mail archive of the mailing list for the binutils project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

linking problem, I messed up but don't know how

Hi All;

This is probably the wrong list, but I thought I'd start here.

I am trying to built a C++ library (GUI) and am having some trouble.
This used to work, but somehow I messed up my system and I need some
help figuring out what to do.

I am running a modified RedHat 6.2 system using gcc-2.95.2 and the
binutils that came with RedHat 6.2.

In June I built this "same" (previous release) library on the system and

everything worked, now it's broken. When I try to run one of the test
programs that come with the library source I get the following error.

lt-button: error in loading shared libraries:
/usr/local/src/fox-0.99.174/src/.libs/ undefined
symbol: __builtin_new

This indicates to me that the standard c++ library was not linked
properly. However, I have no clue how I managed to screw this up. When I

built the previous version of the library in June I did get the new
operator in the library

nm -Bg /usr/local/lib/ | grep new
001f3db4 W __builtin_new
001f3fb4 W __builtin_vec_new
0026fe30 B __new_handler
001f5150 T set_new_handler__FPFv_v

but now I do not get this anymore

nm -Bg /usr/local/src/fox-0.99.174/src/.libs/ | grep
         U __builtin_new
         U __builtin_vec_new
001fa0e8 T inflate_blocks_new
001fb9d0 T inflate_codes_new

To make sure this was not some kind of configuration issue I rebuild the

previous version of the library (didn't install it) and I got exactly
the same error as with the new library. Thus I conclude that I somehow
messed up my linker or compiler or both. I have no clue how I did this,
thus any help in this direction is appreciated.

The standard c++ library is on the system

locate libstdc++ | grep -v src

Another issue I do not understand is that ldd doesn't show the standard
c++ library linked in the working version of the library

ldd /usr/local/lib/ => /usr/X11R6/lib/ (0x4027a000) => /usr/X11R6/lib/ (0x40286000) => /usr/X11R6/lib/ (0x4032a000) => /usr/lib/ (0x40387000) => /usr/lib/ (0x4039c000) => /usr/lib/ (0x403ab000) => /usr/lib/ (0x403ca000) => /lib/ (0x403f4000) => /lib/ (0x40411000) => /lib/ (0x40506000) => /lib/ (0x4051a000)
 /lib/ => /lib/ (0x2aaaa000)

Again, any help to resolve this issue is appreciated.


Robert Schweikert                      MAY THE SOURCE BE WITH YOU                         LINUX

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]