binutils-cvs archive
subject index for April, 2015

This is the mail archive of the binutils-cvs@sourceware.org mailing list for the binutils project.

Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

[binutils-gdb/binutils-2_25-branch] Add support for the Samsung Exynos M1 processor.

[binutils-gdb/binutils-2_25-branch] Automatic date update in version.in

[binutils-gdb/binutils-2_25-branch] Don't pass unadorned zeros to varargs functions

[binutils-gdb/binutils-2_25-branch] Downgrade linker error on protected symbols in .dynbss to a warning

[binutils-gdb/binutils-2_25-branch] opcodes/

[binutils-gdb/binutils-2_25-branch] Relax PR 15228 protected visibility restriction

[binutils-gdb/binutils-2_25-branch] Revert "Add extern_protected_data and set it for x86"

[binutils-gdb/gdb-7.9-branch] Automatic date update in version.in

[binutils-gdb] [AArch64] Add support for the Samsung Exynos M1 processor

[binutils-gdb] [AArch64] Don't try to align insn in non-executale section

[binutils-gdb] [AArch64] Emit DATA_MAP in order within text section

[binutils-gdb] [AArch64] Improve PC-relative relocation check for shared library

[binutils-gdb] [AArch64] PR18270, fix handling of GOT entry for local symbol

[binutils-gdb] [AArch64] use subseg_text_p to check .text

[binutils-gdb] [AArch64] Workaround for Cortex A53 erratum 843419

[binutils-gdb] [ARM] Add support for the Samsung Exynos M1 processor

[binutils-gdb] [ARM] Disassembles SSAT and SSAT16 instructions incorrectly for Thumb-2

[binutils-gdb] [ARM] Update ld testcases

[binutils-gdb] [ARM]: Don't tail-pad over-aligned functions to the alignment boundary.

[binutils-gdb] [ARM]Positively emit symbols for alignment

[binutils-gdb] [Gold, x86_64] Convert mov foo at GOTPCREL(%rip), %reg to lea foo(%rip), %reg

[binutils-gdb] [gold] Rename '--fix-cortex-a53' to '--fix-cortex-a53-843419'.

[binutils-gdb] [gold] The first patch to address cortex-a53 erratum-843419.

[binutils-gdb] Accept odd result in ld-powerpc/tocnovar testcase

[binutils-gdb] Add --compress-debug-sections=[none|zlib|zlib-gnu|zlib-gabi]

[binutils-gdb] Add --with-system-zlib to top level configure

[binutils-gdb] Add -z noextern-protected-data to ld for ELF/x86

[binutils-gdb] Add a dw2-3.S test

[binutils-gdb] Add a testcase for PR ld/18176

[binutils-gdb] Add a testcase for PR ld/18223

[binutils-gdb] Add AArch32 support for arm gold linker.

[binutils-gdb] Add chdr_size, Chdr, Chdr_write and Chdr_data

[binutils-gdb] Add documentation about the interation of the ARM assembler's -EB option and the linker's --be8 opti

[binutils-gdb] Add Elf_Internal_Chdr and ElfXX_External_Chdr

[binutils-gdb] Add extern_protected_data and set it for x86

[binutils-gdb] Add ld_list_options

[binutils-gdb] Add new linker option: --warn-orphan which generates warning messages when orphan sections are dete

[binutils-gdb] Add option --weak-unresolved-symbols to treat unresolved as weak references.

[binutils-gdb] Add option --weak-unresolved-symbols to treat unresolved symbols as weak ref.

[binutils-gdb] Add SHF_COMPRESSED and ELFCOMPRESS_XXX to elfcpp.h

[binutils-gdb] Add SHF_COMPRESSED support to gas and objcopy

[binutils-gdb] Add SHF_COMPRESSED support to readelf

[binutils-gdb] Add support for absolute PE/x86 relocations.

[binutils-gdb] Add support for configuring an aarch64-freebsd target.

[binutils-gdb] Add support for the x86 XSAVE extended state on FreeBSD/x86.

[binutils-gdb] Add support to the RX toolchain to restrict the use of string instructions.

[binutils-gdb] Adds documentation of GAS's .zero directive.

[binutils-gdb] Adds support to the RL78 port for linker relaxation affecting .debug sections.

[binutils-gdb] Adjust src-release.sh for sim using the gdb create-version.sh.

[binutils-gdb] Align .TOC. for PowerPC64

[binutils-gdb] Allow gold to resolve defined TLS symbols in a PIE link.

[binutils-gdb] Also preserve the SHF_COMPRESSED bit

[binutils-gdb] Always set up sh_name in assign_section_numbers

[binutils-gdb] Automatic date update in version.in

[binutils-gdb] Avoid a call to find by using the return value of insert.

[binutils-gdb] Avoid a copy constructor call.

[binutils-gdb] binutils: update my e-mail address

[binutils-gdb] Cast shift expression

[binutils-gdb] Change msp430 emulation to msp430elf

[binutils-gdb] Check dp->prefix_requirement instead

[binutils-gdb] Check GOTOFF reloc against protected data on x86

[binutils-gdb] Convert mov foo at GOT(%reg), %reg to lea foo at GOTOFF(%reg), %reg

[binutils-gdb] Copy is_linker_input to archive member

[binutils-gdb] Correct ld-elf/compressed1e.d to use notarget and for cris-elf, not cris-*.

[binutils-gdb] Correct setting of elf_list_options

[binutils-gdb] Define SEC_MEP_VLIW in bfd/section.c

[binutils-gdb] Delay setting up compressed debug section names

[binutils-gdb] Display --interleave[=<number>]

[binutils-gdb] doc/c-rx.texi: Fix markup typos in last change.

[binutils-gdb] Don't call getpagesize more than once

[binutils-gdb] Don't change compressed input debug section names

[binutils-gdb] Don't check object claimed by plugin

[binutils-gdb] Don't hardcode offset of .shstrtab section

[binutils-gdb] Downgrade linker error on protected symbols in .dynbss to a warning

[binutils-gdb] Eat newlines inside INPUT statements in linker scripts

[binutils-gdb] Enable ELF ld_list_options for --enable-targets=all

[binutils-gdb] Ensure that dynamically loaded libraries won't use separate copies of GNU_UNIQUE symbols.

[binutils-gdb] Extend test for local labels to include fake symbols and local labels with a numeric suffix.

[binutils-gdb] Extract get_uncompressed_size

[binutils-gdb] Fix 18354

[binutils-gdb] Fix an internal error in GAS when assembling a bogus piece of source code.

[binutils-gdb] Fix avr compiler warning

[binutils-gdb] Fix compile time warning messages about variables being used before they are initialised.

[binutils-gdb] Fix compile time warnings about a local variable being used before it is set.

[binutils-gdb] Fix handling of relocs for the MeP target.

[binutils-gdb] Fix ld eelf32ppcvxworks.c dependencies

[binutils-gdb] Fix r6-branch-constraints test when run with n64 as default ABI

[binutils-gdb] Fix reading of .debug_str_offsets{,.dwo} twice.

[binutils-gdb] Fix the binutils readelf.ss test for the AArch64 target.

[binutils-gdb] Fix the signature of a virtual method to match the one in the parent class.

[binutils-gdb] Fix typo

[binutils-gdb] Fix typo in commit 6ff71e76

[binutils-gdb] Fix typo in last ChangeLog.

[binutils-gdb] Fixes a bug in the microblaze assembler where it would not complain about constants larger than 32-b

[binutils-gdb] Fixes for a small number of compiler warnings

[binutils-gdb] GAS ARM: Warn if the user creates a symbol with the same name as an instruction.

[binutils-gdb] gas thunderx support

[binutils-gdb] Handle invalid prefixes for rdrand and rdseed

[binutils-gdb] i386: Allow copy relocs for building PIE

[binutils-gdb] If a range is missing, assume the input address is mapped.

[binutils-gdb] Improve ODR checking in gold.

[binutils-gdb] Improve warning messages for la/dla

[binutils-gdb] Initialize pagesize_m1 in bfd_cache_init

[binutils-gdb] Iterate ELF sections by pointer

[binutils-gdb] libiberty/setenv.c: Do not declare environ if defined as a macro.

[binutils-gdb] Link the last *normal against libfoozlib.so

[binutils-gdb] Make is_zlib_supported always return 1

[binutils-gdb] Make RL78 disassembler and simulator respect ISA for mul/div

[binutils-gdb] Mark _init and _fini for --gc-sections

[binutils-gdb] Mention --compress-debug-sections=[none|zlib|zlib-gnu|zlib-gabi]

[binutils-gdb] Merge include/partition.h from GCC.

[binutils-gdb] Modify get_reloc_section for targets that map .got.plt to .got

[binutils-gdb] Non-alloc sections don't belong in PT_LOAD segments

[binutils-gdb] opcodes/

[binutils-gdb] PowerPC gold assertion on missing global entry stub

[binutils-gdb] PowerPC non-PIC to PIC editing for protected var access

[binutils-gdb] Prevent multiple definitions for _HEAP_START, _HEAP_MAX, and _STACK_START when performing a relocata

[binutils-gdb] Properly check --compress-debug-sections=XXX

[binutils-gdb] Regenerate configure in bfd/binutils/gas/gdb

[binutils-gdb] Regenerate configure in bfd/binutils/gas/gdb/gold

[binutils-gdb] Regenerate configure in gold

[binutils-gdb] Remove "/dev/null" from remote_exec

[binutils-gdb] Remove an extra ';'

[binutils-gdb] Remove BNDPLT and add PARSE_AND_LIST_ARGS_CASE_Z

[binutils-gdb] Remove is_zlib_supported

[binutils-gdb] Remove the unused PREFIX_UD_XXX

[binutils-gdb] Remove unused functions in tc-aarch64.c.

[binutils-gdb] Replace mandatory_prefix with prefix_requirement

[binutils-gdb] Replace SYMBOLIC_BIND with SYMBOL_REFERENCES_LOCAL

[binutils-gdb] Replace uncompressed_size_buffer with compressed_size_buffer

[binutils-gdb] Revert "Add extern_protected_data and set it for x86"

[binutils-gdb] Revert the last 2 commits on pagesize_m1

[binutils-gdb] Rewrite relro adjusting code

[binutils-gdb] S/390: Fix gotreloc_31-1 testcase.

[binutils-gdb] S/390: Fixes for z13 instructions.

[binutils-gdb] S/390: z13 use GNU attribute to indicate vector ABI

[binutils-gdb] Second fix for microblaze gas port's ability to parse constants.

[binutils-gdb] Set zlibdir/zlibinc with top_builddir/top_srcdir

[binutils-gdb] Silence texinfo 5.1 warnings

[binutils-gdb] Skip empty EMULATION_NAME

[binutils-gdb] Skip the compressed1d test for targets which do not use the elf32.em linker emulation file.

[binutils-gdb] Start of relro segment adjustment

[binutils-gdb] Tidy PowerPC gold find_global_entry uses

[binutils-gdb] Treat assembler generated local labels as local.

[binutils-gdb] Undef elf_backend_post_process_headers for Solaris

[binutils-gdb] Unset zlibdir/zlibinc only for --with-system-zlib

[binutils-gdb] Update comments in compress.c

[binutils-gdb] Update French translation of ld strings.

[binutils-gdb] Updated translations for various binutils components.

[binutils-gdb] Updates the description of GAS's .set directive, to note that for some targets a symbolic value can

[binutils-gdb] Use "else if" on cpu_arch_isa

[binutils-gdb] Use bfd_alloc for compressed section contents

[binutils-gdb] Use bfd_putb64/bfd_getb64

[binutils-gdb] Use LIFO instead of FIFO to implement gc's transitive closure.

[binutils-gdb] Work around a GCC uninitialized warning bug

[binutils-gdb] x86: disambiguate disassembly of certain AVX512 insns

[binutils-gdb] x86: don't require operand size specification for AVX512 broadcasts

[binutils-gdb] x86: Use individual prefix control for each opcode.

[binutils-gdb] Xfail cris and frv for ld-elf/compressed1e.d

[binutils-gdb] xfail pr18223 test for tic6x

[binutils-gdb] Xfail the compressed debug sections

[binutils-gdb] xtensa: optimize check_section_ebb_pcrels_fit

[binutils-gdb] xtensa: optimize find_removed_literal

[binutils-gdb] xtensa: optimize removed_by_actions

[binutils-gdb] xtensa: replace action list with splay tree

[binutils-gdb] xtensa: update bfd/Changelog

[binutils-gdb] Yet another warning fix


Indexes: [Date Index] [Subject Index] [Author Index] [Thread Index]
Site Nav: [Browse other archives for this mailing list]
[Browse other mailing lists at this site]
Search: Limit to:

Mail converted by MHonArc